No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a BFD for Perlink Session to Detect Eth-Trunk Member Link Faults in a VLAN

Example for Configuring a BFD for Perlink Session to Detect Eth-Trunk Member Link Faults in a VLAN

Networking Requirements

In Figure 2-27, SwitchA and SwitchB are directly connected through Eth-Trunk interfaces, which join VLAN 100. BFD sessions can be bound to VLANIF interfaces to detect the connectivity of the Eth-Trunk between SwitchA and SwitchB. If BFD for IP single-hop sessions is used, BFD will select one of the member links of the Eth-Trunk to monitor the status of the Eth-Trunk. Once BFD detects that the selected member link is Down, it considers the Eth-Trunk to be Down even if other member links of the Eth-Trunk are Up. To prevent BFD from incorrectly detecting the Eth-Trunk state, you can deploy BFD for Perlink sessions instead of BFD for IP single-hop sessions.

Figure 2-27 Networking diagram for configuring a BFD for Perlink session to detect Eth-Trunk member link faults in a VLAN

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk interface on SwitchA and SwitchB, and add Ethernet physical interfaces to the Eth-Trunk interface.

  2. Create a VLAN on SwitchA and SwitchB, add the Eth-Trunk interface to the VLAN, and create a VLANIF interface to implement Layer 3 interworking between SwitchA and SwitchB through the VLANIF interface.
  3. Configure a BFD for Perlink session on SwitchA to monitor the Eth-Trunk member links between SwitchA and SwitchB.

Procedure

  1. Create an Eth-Trunk interface on SwitchA and SwitchB, and add Ethernet physical interfaces to the Eth-Trunk interface.

    # Configure SwitchA. The configuration of SwitchB is similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] interface eth-trunk 1
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit
    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] eth-trunk 1
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit
    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] eth-trunk 1
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit

  2. Create a VLAN on SwitchA and SwitchB, add the Eth-Trunk interface to the VLAN, and create a VLANIF interface to implement Layer 3 interworking between SwitchA and SwitchB through the VLANIF interface.

    # Configure SwitchA. The configuration of SwitchB is similar to the configuration of SwitchA.

    [~SwitchA] vlan 100
    [*SwitchA-vlan100] commit
    [~SwitchA-vlan100] quit
    [~SwitchA] interface eth-trunk 1
    [~SwitchA-Eth-Trunk1] port link-type trunk
    [*SwitchA-Eth-Trunk1] port trunk allow-pass vlan 100
    [*SwitchA-Eth-Trunk1] commit
    [~SwitchA-Eth-Trunk1] quit
    [~SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.5 24
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit

  3. Configure a BFD for Perlink session on SwitchA to monitor the Eth-Trunk member links between SwitchA and SwitchB.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] bfd atob bind peer-ip 10.1.1.6 interface vlanif 100 source-ip 10.1.1.5 per-link one-arm-echo
    [*SwitchA-bfd-session-atob] commit
    [~SwitchA-bfd-session-atob] quit

  4. Verify the configuration.

    Run the display bfd perlink session command on SwitchA. The command output shows that three BFD sessions have been established and are in Up state. The discriminators of the three BFD sessions are dynamically allocated. The BFD session bound to VLANIF 100 is the management session, and the other two are BFD sub-sessions and are bound to 10GE1/0/1 and 10GE1/0/2.

    [~SwitchA] display bfd perlink session
    Total Up/Down Main Session Number : 1/0                                         
    Total Up/Down Sub Session Number  : 2/0                                         
    --------------------------------------------------------------------------------
      Name                   : atob                                                 
      State                  : Up                                                   
      Local Discriminator    : 1048577                                              
      Remote Discriminator   : 1048577                                              
      Session Detect Mode    : Asynchronous Mode With Echo Function                 
      BFD Bind Type          : Interface(Vlanif100)                                  
      Bind Session Type      : Static_Auto                                          
      Bind Peer IP Address   : 10.1.1.6                                         
      Bind Source IP Address : 10.1.1.5                                         
      FSM Board Id           : -                                                    
      TOS-EXP                : 7                                                    
      Min Tx Interval (ms)   : 1000                                                 
      Min Rx Interval (ms)   : 1000                                                 
      Local Detect Multi     : 3                                                    
      WTR Interval (ms)      : -                                                    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : AUTO                                                 
      Sub Session Count      : 2                                                    
    --------------------------------------------------------------------------------
          Sub Session Number     : 1                                         
          State                  : Up                                               
          Local Discriminator    : 16387                                            
          Remote Discriminator   : 16387                                            
          BFD Bind Type          : Interface(10GE1/0/1)                            
          Bind Session Type      : Dynamic                                          
          FSM Board Id           : 1                                                
          Min Tx Interval (ms)   : 1000                                             
          Min Rx Interval (ms)   : 1000                                             
          Local Detect Multi     : 3                                                
          Actual Tx Interval (ms): 1000                                             
          Actual Rx Interval (ms): 1000                                             
          Active Multi           : 3                                                
          Detect Interval (ms)   : 3000                                             
          Destination Port       : 3784                                             
          Last Local Diagnostic  : No Diagnostic                                    
    --------------------------------------------------------------------------------
          Sub Session Number     : 2                                         
          State                  : Up                                               
          Local Discriminator    : 16388                                            
          Remote Discriminator   : 16388                                            
          BFD Bind Type          : Interface(10GE1/0/2)                            
          Bind Session Type      : Dynamic                                          
          FSM Board Id           : 1                                                
          Min Tx Interval (ms)   : 1000                                             
          Min Rx Interval (ms)   : 1000                                             
          Local Detect Multi     : 3                                                
          Actual Tx Interval (ms): 1000                                             
          Actual Rx Interval (ms): 1000                                             
          Active Multi           : 3                                                
          Detect Interval (ms)   : 3000                                             
          Destination Port       : 3784                                             
          Last Local Diagnostic  : No Diagnostic                                    
    --------------------------------------------------------------------------------

    # Run the shutdown command on the 10GE1/0/1 interface of SwitchA to simulate a link fault.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] shutdown
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    # Run the display bfd perlink session command on SwitchA to view the BFD session status. The command output shows that the BFD sub-session bound to 10GE1/0/1 is in Down state and that the BFD sub-session bound to 10GE1/0/2 and the BFD management session bound to VLANIF 100 are still in Up state.

    [~SwitchA] display bfd perlink session
    Total Up/Down Main Session Number : 1/0                                         
    Total Up/Down Sub Session Number  : 1/1                                         
    --------------------------------------------------------------------------------
      Name                   : atob                                               
      State                  : Up                                                   
      Local Discriminator    : 1048577                                              
      Remote Discriminator   : 1048577                                              
      Session Detect Mode    : Asynchronous Mode With Echo Function                 
      BFD Bind Type          : Interface(Vlanif100)                                  
      Bind Session Type      : Static_Auto                                          
      Bind Peer IP Address   : 10.1.1.6                                         
      Bind Source IP Address : 10.1.1.5                                         
      FSM Board Id           : -                                                    
      TOS-EXP                : 7                                                    
      Min Tx Interval (ms)   : 1000                                                 
      Min Rx Interval (ms)   : 1000                                                 
      Local Detect Multi     : 3                                                    
      WTR Interval (ms)      : -                                                    
      Last Local Diagnostic  : No Diagnostic                                        
      Bind Application       : AUTO                                                 
      Sub Session Count      : 2                                                    
    --------------------------------------------------------------------------------
          Sub Session Number     : 1                                         
          State                  : Down                                             
          Local Discriminator    : 16387                                            
          Remote Discriminator   : 16387                                            
          BFD Bind Type          : Interface(10GE1/0/1)                            
          Bind Session Type      : Dynamic                                          
          FSM Board Id           : 1                                                
          Min Tx Interval (ms)   : 1000                                             
          Min Rx Interval (ms)   : 1000                                             
          Local Detect Multi     : 3                                                
          Actual Tx Interval (ms): 10963                                            
          Actual Rx Interval (ms): 10963                                            
          Active Multi           : 3                                                
          Detect Interval (ms)   : -                                                
          Destination Port       : 3784                                             
          Last Local Diagnostic  : Control Detection Time Expired                   
    --------------------------------------------------------------------------------
          Sub Session Number     : 2                                         
          State                  : Up                                               
          Local Discriminator    : 16388                                            
          Remote Discriminator   : 16388                                            
          BFD Bind Type          : Interface(10GE1/0/2)                            
          Bind Session Type      : Dynamic                                          
          FSM Board Id           : 1                                                
          Min Tx Interval (ms)   : 1000                                             
          Min Rx Interval (ms)   : 1000                                             
          Local Detect Multi     : 3                                                
          Actual Tx Interval (ms): 1000                                             
          Actual Rx Interval (ms): 1000                                             
          Active Multi           : 3                                                
          Detect Interval (ms)   : 3000                                             
          Destination Port       : 3784                                             
          Last Local Diagnostic  : No Diagnostic                                    
    --------------------------------------------------------------------------------

    # Run the shutdown command on the 10GE1/0/2 interface of SwitchA. The command output shows that all the BFD sessions are in Down state.

    [~SwitchA] interface 10ge 1/0/2
    [~SwitchA-10GE1/0/2] shutdown
    [*SwitchA-10GE1/0/2] commit
    [~SwitchA-10GE1/0/2] quit
    [~SwitchA] display bfd perlink session
    Total Up/Down Main Session Number : 0/1                                         
    Total Up/Down Sub Session Number  : 0/2                                         
    --------------------------------------------------------------------------------
      Name                   : atob                                               
      State                  : Down                                                 
      Local Discriminator    : 1048577                                              
      Remote Discriminator   : 1048577                                              
      Session Detect Mode    : Asynchronous Mode With Echo Function                 
      BFD Bind Type          : Interface(Vlanif100)                                  
      Bind Session Type      : Static_Auto                                          
      Bind Peer IP Address   : 10.1.1.6                                         
      Bind Source IP Address : 10.1.1.5                                         
      FSM Board Id           : -                                                    
      TOS-EXP                : 7                                                    
      Min Tx Interval (ms)   : 1000                                                 
      Min Rx Interval (ms)   : 1000                                                 
      Local Detect Multi     : 3                                                    
      WTR Interval (ms)      : -                                                    
      Last Local Diagnostic  : Control Detection Time Expired                       
      Bind Application       : AUTO                                                 
      Sub Session Count      : 2                                                    
    --------------------------------------------------------------------------------
          Sub Session Number     : 1                                         
          State                  : Down                                             
          Local Discriminator    : 16387                                            
          Remote Discriminator   : 16387                                            
          BFD Bind Type          : Interface(10GE1/0/1)                            
          Bind Session Type      : Dynamic                                          
          FSM Board Id           : 1                                                
          Min Tx Interval (ms)   : 1000                                             
          Min Rx Interval (ms)   : 1000                                             
          Local Detect Multi     : 3                                                
          Actual Tx Interval (ms): 10963                                            
          Actual Rx Interval (ms): 10963                                            
          Active Multi           : 3                                                
          Detect Interval (ms)   : -                                                
          Destination Port       : 3784                                             
          Last Local Diagnostic  : Control Detection Time Expired                   
    --------------------------------------------------------------------------------
          Sub Session Number     : 2                                         
          State                  : Down                                             
          Local Discriminator    : 16388                                            
          Remote Discriminator   : 16388                                            
          BFD Bind Type          : Interface(10GE1/0/2)                            
          Bind Session Type      : Dynamic                                          
          FSM Board Id           : 1                                                
          Min Tx Interval (ms)   : 1000                                             
          Min Rx Interval (ms)   : 1000                                             
          Local Detect Multi     : 3                                                
          Actual Tx Interval (ms): 4768                                             
          Actual Rx Interval (ms): 4768                                             
          Active Multi           : 3                                                
          Detect Interval (ms)   : -                                                
          Destination Port       : 3784                                             
          Last Local Diagnostic  : Control Detection Time Expired                   
    --------------------------------------------------------------------------------

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    bfd
    #
    interface Vlanif100
     ip address 10.1.1.5 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/1
     eth-trunk 1
    #
    interface 10GE1/0/2
     eth-trunk 1
    #
    bfd atob bind peer-ip 10.1.1.6 interface Vlanif100 source-ip 10.1.1.5 per-link one-arm-echo
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.6 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface 10GE1/0/1
     eth-trunk 1
    #
    interface 10GE1/0/2
     eth-trunk 1
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075366

Views: 18784

Downloads: 61

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next