No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a VRRP Group in Single-gateway Load Balancing Mode

Example for Configuring a VRRP Group in Single-gateway Load Balancing Mode

Networking Requirements

In Figure 3-20, HostA and HostC are dual-homed to SwitchA and SwitchB. Some users want to use SwitchA to forward data traffic and use SwitchB as the backup. Other users want to use SwitchB to forward data traffic and use SwitchA as the backup. SwitchA and SwitchB used as masters in different VRRP groups can back up each other and load balance data traffic.

Figure 3-20 Network diagram for configuring a VRRP group in single-gateway load balancing mode

Device

Interface

VLANIF Interface

IP Address

SwitchA

10GE1/0/1

VLANIF 300

192.168.1.1/24

10GE1/0/2

VLANIF 100

10.1.1.1/24

SwitchB

10GE1/0/1

VLANIF 200

192.168.2.1/24

10GE1/0/2

VLANIF 100

10.1.1.2/24

SwitchC

10GE1/0/1

VLANIF 300

192.168.1.2/24

10GE1/0/2

VLANIF 200

192.168.2.2/24

10GE1/0/3

VLANIF 400

172.16.1.1/24

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface and configure a routing protocol to ensure network connectivity.

  2. Disable the ARP fast reply function on SwitchA and SwitchB.

  3. Configure two VRRP groups on SwitchA and SwitchB. SwitchA is configured as the master in VRRP group 1. SwitchB is configured as the master in VRRP group 2 so that traffic can be load balanced.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 300
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 300
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/2] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ip address 10.1.1.1 24
    [*SwitchA-Vlanif100] quit
    [*SwitchA] interface vlanif 300
    [*SwitchA-Vlanif300] ip address 192.168.1.1 24
    [*SwitchA-Vlanif300] quit
    [*SwitchA] commit

    # Configure OSPF between SwitchA, SwitchB, and SwitchC. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    [~SwitchA] ospf 1
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] commit
    [~SwitchA-ospf-1-area-0.0.0.0] quit
    [~SwitchA-ospf-1] quit

  2. Disable the ARP fast reply function.

    # Disable the ARP fast reply function on SwitchA.

    [~SwitchA] arp fast-reply disable
    [*SwitchA] commit

    # Disable the ARP fast reply function on SwitchB.

    [~SwitchB] arp fast-reply disable
    [*SwitchB] commit

  3. Configure VRRP groups.

    # Create VRRP groups 1 and 2 on VLANIF100 of SwitchA, set the priority to 120 for SwitchA in VRRP group 1 so that SwitchA serves as the master in VRRP group 1, and set the priority to 100 for SwitchA in VRRP group 2 so that SwitchA serves as the backup in VRRP group 2.

    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [*SwitchA-Vlanif100] vrrp vrid 1 priority 120
    [*SwitchA-Vlanif100] vrrp vrid 2

    # On VLANIF100 of SwitchA, configure VRRP group 1 as a load-balance redundancy group (LBRG) and add VRRP group 2 to the LBRG.

    [*SwitchA-Vlanif100] vrrp vrid 1 load-balance
    [*SwitchA-Vlanif100] vrrp vrid 2 join load-balance-vrrp vrid 1
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit

    # Create VRRP groups 1 and 2 on VLANIF100 of SwitchB in VRRP group 2 so that SwitchB serves as the master in VRRP group 2 and as the backup in VRRP group 1.

    [~SwitchB] interface vlanif 100
    [~SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [*SwitchB-Vlanif100] vrrp vrid 2
    [*SwitchB-Vlanif100] vrrp vrid 2 priority 120

    # On VLANIF100 of SwitchB, configure VRRP group 1 as an LBRG and add VRRP group 2 to the LBRG.

    [*SwitchB-Vlanif100] vrrp vrid 1 load-balance
    [*SwitchB-Vlanif100] vrrp vrid 2 join load-balance-vrrp vrid 1
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit

  4. Verify the configuration.

    Run the display vrrp command on SwitchA. The command output shows that SwitchA serves as the master in the LBRG and as a backup in the LBRG member group.

    [~SwitchA] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State         : Master
    Virtual IP    : 10.1.1.111
    Master IP     : 10.1.1.1
    PriorityRun    : 120
    PriorityConfig : 120
    MasterPriority : 120
    Preempt        : YES   Delay Time : 0s    Remain : --
    TimerRun       : 1s
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Load-Balance
    Create Time       : 2012-10-19 03:29:46
    Last Change Time  : 2012-10-19 03:29:51
    
    Vlanif100 | Virtual Router 2
    State         : Backup
    Virtual IP    : 0.0.0.0
    Master IP     : 10.1.1.2
    PriorityRun    : 100
    PriorityConfig : 100
    MasterPriority : 120
    Preempt        : YES   Delay Time : 0s    Remain : --
    TimerRun       : 1s
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0102
    Check TTL      : YES
    Config Type    : Load-Blance-Member
    Create Time       : 2012-10-19 03:30:17
    Last Change Time  : 2012-10-19 03:33:05
                                               

    Run the display vrrp command on SwitchB. The command output shows that SwitchB serves as a backup in the LBRG and as the master in the LBRG member group.

    [~SwitchB] display vrrp verbose
    Vlanif100 | Virtual Router 1
    State         : Backup
    Virtual IP    : 10.1.1.111
    Master IP     : 10.1.1.1
    PriorityRun    : 100
    PriorityConfig : 100
    MasterPriority : 120
    Preempt        : YES   Delay Time : 0s    Remain : --
    TimerRun       : 1s
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0101
    Check TTL      : YES
    Config Type    : Load-Balance
    Create Time       : 2012-10-19 03:32:29
    Last Change Time  : 2012-10-19 03:32:31
    
    Vlanif100 | Virtual Router 2
    State         : Master
    Virtual IP    : 0.0.0.0
    Master IP     : 10.1.1.2
    PriorityRun    : 120
    PriorityConfig : 120
    MasterPriority : 120
    Preempt        : YES   Delay Time : 0s    Remain : --
    TimerRun       : 1s
    TimerConfig    : 1s
    Auth Type      : NONE
    Virtual MAC    : 0000-5e00-0102
    Check TTL      : YES
    Config Type    : Load-Balance-Member
    Create Time       : 2012-10-19 03:32:51
    Last Change Time  : 2012-10-19 03:33:04

    Run the display vrrp load-balance command on Switch A. The command output shows information about the LBRG and its member group on Switch A.

    [~SwitchA] display vrrp load-balance member-vrrp
    Interface: Vlanif100, load-balance-vrrp vrid: 1, state: Master
      Member-vrrp number: 1
        Member-vrrp vrid: 2, state: Backup

    Run the display vrrp load-balance command on Switch B. The command output shows information about the LBRG and its member group on Switch B.

    [~SwitchB] display vrrp load-balance member-vrrp
    Interface: Vlanif100, load-balance-vrrp vrid: 1, state: Backup
      Member-vrrp number: 1
        Member-vrrp vrid: 2, state: Master

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 300
    #
    arp fast-reply disable
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 load-balance
     vrrp vrid 1 priority 120
     vrrp vrid 2
     vrrp vrid 2 join load-balance-vrrp vrid 1
    #
    interface Vlanif300
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    arp fast-reply disable
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 load-balance
     vrrp vrid 2
     vrrp vrid 2 priority 120
     vrrp vrid 2 join load-balance-vrrp vrid 1
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif300
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif400
     ip address 172.16.1.1 255.255.255.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075366

Views: 19092

Downloads: 61

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next