No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Reliability

CloudEngine 8800, 7800, 6800, and 5800 V200R005C10

This document describes the configurations of Reliability, including BFD Configuration, VRRP Configuration, DLDP Configuration, Smart Link and Monitor Link Configuration, EFM Configuration, and CFM Configuration.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring a VRRP6 Group in Single-gateway Load Balancing Mode

Example for Configuring a VRRP6 Group in Single-gateway Load Balancing Mode

Networking Requirements

In Figure 3-30, HostA and HostC are dual-homed to SwitchA and SwitchB. Some users want to use SwitchA to forward data traffic and use SwitchB as the backup. Other users want to use SwitchB to forward data traffic and use SwitchA as the backup. SwitchA and SwitchB used as masters in different VRRP groups can back up each other and load balance data traffic.

Figure 3-30 Networking diagram for configuring a VRRP6 group in load balancing mode

Device

Interface

VLANIF Interface

IP Address

SwitchA

10GE1/0/1

VLANIF 300

2002::1/64

10GE1/0/2

VLANIF 100

FC00::1/64

SwitchB

10GE1/0/1

VLANIF 200

2001::1/64

10GE1/0/2

VLANIF 100

FC00::2/64

SwitchC

10GE1/0/1

VLANIF 300

2002::2/64

10GE1/0/2

VLANIF 200

2001::2/64

10GE1/0/3

VLANIF 400

2003::2/64

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IPv6 address to each interface and configure a routing protocol to ensure network connectivity.

  2. Configure two VRRP6 groups on SwitchA and SwitchB. SwitchA is configured as the master in VRRP6 group 1. SwitchB is configured as the master in VRRP6 group 2.

Procedure

  1. Configure devices to ensure network connectivity.

    # Assign an IPv6 address to each interface. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    <HUAWEI> system-view
    [~HUAWEI] sysname SwitchA
    [*HUAWEI] commit
    [~SwitchA] vlan batch 100 300
    [*SwitchA] interface 10ge 1/0/1
    [*SwitchA-10GE1/0/1] port link-type trunk
    [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 300
    [*SwitchA-10GE1/0/1] port trunk pvid vlan 300
    [*SwitchA-10GE1/0/1] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/1] quit
    [*SwitchA] interface 10ge 1/0/2
    [*SwitchA-10GE1/0/2] port link-type trunk
    [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 100
    [*SwitchA-10GE1/0/2] port trunk pvid vlan 100
    [*SwitchA-10GE1/0/2] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/2] quit
    [*SwitchA] interface vlanif 100
    [*SwitchA-Vlanif100] ipv6 enable
    [*SwitchA-Vlanif100] ipv6 address FC00::1 64
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    [~SwitchA] interface vlanif 300
    [*SwitchA-Vlanif300] ipv6 enable
    [*SwitchA-Vlanif300] ipv6 address 2002::1 64
    [*SwitchA-Vlanif300] commit
    [~SwitchA-Vlanif300] quit

    # Configure OSPFv3 between SwitchA, SwitchB, and SwitchC. SwitchA is used as an example. The configurations of SwitchB and SwitchC are similar to the configuration of SwitchA.

    [~SwitchA] ospfv3
    [* SwitchA-ospfv3-1] router-id 1.1.1.1
    [*SwitchA-ospfv3-1] commit
    [~SwitchA-ospfv3-1] quit
    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] ospfv3 1 area 0
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit
    [~SwitchA] interface vlanif 300
    [~SwitchA-Vlanif300] ospfv3 1 area 0
    [*SwitchA-Vlanif300] commit
    [~SwitchA-Vlanif300] quit

  2. Configure VRRP6 groups.

    # Configure VRRP6 groups 1 and 2 on VLANIF100 of SwitchA, set the priority to 120 for SwitchA in VRRP6 group 1 so that SwitchA serves as the master in VRRP6 group 1, and set the priority to 100 for SwitchA in VRRP6 group 2 so that SwitchA serves as the backup in VRRP6 group 2.

    [~SwitchA] interface vlanif 100
    [~SwitchA-Vlanif100] vrrp6 vrid 1 virtual-ip FE80::1 link-local
    [*SwitchA-Vlanif100] vrrp6 vrid 1 virtual-ip FC00::100
    [*SwitchA-Vlanif100] vrrp6 vrid 1 priority 120
    [*SwitchA-Vlanif100] vrrp6 vrid 2

    # On VLANIF100 of SwitchA, configure VRRP6 group 1 as a Load-Balance Redundancy Group (LBRG) and add VRRP6 group 2 to the LBRG.

    [*SwitchA-Vlanif100] vrrp6 vrid 1 load-balance
    [*SwitchA-Vlanif100] vrrp6 vrid 2 join load-balance-vrrp vrid 1
    [*SwitchA-Vlanif100] commit
    [~SwitchA-Vlanif100] quit

    # Configure VRRP6 groups 1 and 2 on VLANIF100 of SwitchB, set the priority to 100 for SwitchB in VRRP6 group 1 so that SwitchB serves as the backup in VRRP6 group 1, and set the priority to 120 for SwitchB in VRRP6 group 2 so that SwitchB serves as the master in VRRP6 group 2.

    [~SwitchB] interface vlanif 100
    [~SwitchB-Vlanif100] vrrp6 vrid 1 virtual-ip FE80::1 link-local
    [*SwitchB-Vlanif100] vrrp6 vrid 1 virtual-ip FC00::100
    [*SwitchB-Vlanif100] vrrp6 vrid 2
    [*SwitchB-Vlanif100] vrrp6 vrid 2 priority 120
    [*SwitchB-Vlanif100] commit

    # On VLANIF100 of SwitchB, configure VRRP6 group 1 as an LBRG and add VRRP6 group 2 to the LBRG.

    [*SwitchB-Vlanif100] vrrp6 vrid 1 load-balance
    [*SwitchB-Vlanif100] vrrp6 vrid 2 join load-balance-vrrp vrid 1
    [*SwitchB-Vlanif100] commit
    [~SwitchB-Vlanif100] quit

  3. Verify the configuration.

    # Run the display vrrp6 verbose command on SwitchA. The command output shows that SwitchA serves as the master in the LBRG and as a backup in the LBRG member group.

    [~SwitchA] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Master
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : FE80::218:82FF:FED3:2AF3
    PriorityRun     : 120
    PriorityConfig  : 120
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 0s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201
    Check hop limit : YES
    Config Type     : Load-Balance
    Create Time       : 2013-07-27 20:15:46
    Last Change Time  : 2013-07-27 20:15:46
    
    Vlanif100 | Virtual Router 2
    State           : Backup
    Virtual IP      : ::
    Master IP       : FE80::218:82FF:FE68:7455
    PriorityRun     : 100
    PriorityConfig  : 100
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 0s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0202
    Check hop limit : YES
    Config Type     : Load-Balance-Member
    Create Time       : 2013-07-27 20:17:46
    Last Change Time  : 2013-07-27 20:17:46

    # Run the display vrrp command on SwitchB. The command output shows that SwitchB serves as a backup in the LBRG and as the master in the LBRG member group.

    [~SwitchB] display vrrp6 verbose
    Vlanif100 | Virtual Router 1
    State           : Backup
    Virtual IP      : FE80::1
                      FC00::100
    Master IP       : FE80::218:82FF:FED3:2AF3
    PriorityRun     : 100
    PriorityConfig  : 100
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 0s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0201
    Check hop limit : YES
    Config Type     : Load-Balance
    Create Time       : 2013-07-27 20:19:46
    Last Change Time  : 2013-07-27 20:19:46
    
    Vlanif100 | Virtual Router 2
    State           : Master
    Virtual IP      : ::
    Master IP       : FE80::218:82FF:FE68:7455
    PriorityRun     : 120
    PriorityConfig  : 120
    MasterPriority  : 120
    Preempt         : YES   Delay Time : 0s   Remain : --
    TimerRun        : 100cs
    TimerConfig     : 100cs
    Virtual MAC     : 0000-5e00-0202
    Check hop limit : YES
    Config Type     : Load-Balance-Member
    Create Time       : 2013-07-27 20:21:46
    Last Change Time  : 2013-07-27 20:21:46

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 300
    #
    ospfv3 1
     router-id 1.1.1.1
     area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00::1/64
     vrrp6 vrid 1 virtual-ip FE80::1 link-local
     vrrp6 vrid 1 virtual-ip FC00::100
     vrrp6 vrid 1 load-balance
     vrrp6 vrid 1 priority 120
     vrrp6 vrid 2
     vrrp6 vrid 2 join load-balance-vrrp vrid 1
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address 2002::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 300
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    ospfv3 1
     router-id 2.2.2.2
     area 0.0.0.0
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address FC00::2/64
     vrrp6 vrid 1 virtual-ip FE80::1 link-local
     vrrp6 vrid 1 virtual-ip FC00::100
     vrrp6 vrid 1 load-balance
     vrrp6 vrid 2
     vrrp6 vrid 2 priority 120
     vrrp6 vrid 2 join load-balance-vrrp vrid 1
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2001::1/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 200
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    ospfv3 1
     router-id 3.3.3.3
     area 0.0.0.0
    #
    interface Vlanif200
     ipv6 enable
     ipv6 address 2001::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif300
     ipv6 enable
     ipv6 address 2002::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface Vlanif400
     ipv6 enable
     ipv6 address 2003::2/64
     ospfv3 1 area 0.0.0.0
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 300
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 300
    #
    interface 10GE1/0/2
     port link-type trunk
     port trunk pvid vlan 200
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 200
    #
    interface 10GE1/0/3
     port link-type trunk
     port trunk pvid vlan 400
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 400
    #
    return
Translation
Download
Updated: 2019-04-03

Document ID: EDOC1100075366

Views: 19312

Downloads: 61

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next