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OceanStor BCManager 6.5.0 eReplication User Guide 02

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What Can I Do If a Planned Migration or Fault Recovery Fails Due to Specified Parameter Errors

What Can I Do If a Planned Migration or Fault Recovery Fails Due to Specified Parameter Errors

Symptom

A planned migration or fault recovery fails due to resource limitations of the target cluster or other reasons.

Possible Causes

The IP address of the storage device at the DR center or target cluster is incorrectly specified.

Fault Diagnosis

Manually clear VMs, datastores, or other residuals generated during the recovery plan execution, specify the correct parameters, and perform the recovery plan again.

Procedure

  1. View the execution records of the recovery plan to ensure whether registered VMs exist.

    • If yes, go to 2.
    • If no, go to 3.

  2. Log in to vCenter, power off VMs registered on 1, and remove the VMs from vCenter.

  3. View the execution records of the recovery plan to ensure whether datastores have been created.

    • If yes, go to 4.
    • If no, go to 5.

  4. On the specified cluster or host where the recovery plan is executed, uninstall all created data.

  5. View the execution records of the recovery plan to ensure whether datastores have been created based on NAS file systems.

    • If yes, go to 8.
    • If no, go to 6.

  6. View the execution records of the recovery plan to ensure whether mapped LUNs exist.

    • If yes, go to 7.
    • If no, go to 8.

  7. On a host, separate the mapped LUNs, and scan for storage devices of other hosts in the cluster.



  8. View the execution records of the recovery plan to ensure whether datastores have been created.

    • If yes, go to 9.
    • If no, go to 10.

  9. Log in to the storage device at the DR center, cancel the mapping relationship of LUNs or NAS file systems used by the host and protected object of the target cluster, and recover the remote replication pair or consistency group used by the protected groups into the synchronous state.
  10. View the recovery plan, and ensure whether exiting datastores are successfully uninstalled from the production center.

    • If yes, go to 11.
    • If no, go to 12.

  11. Create a datastore.

    • If the datastore is to be created based on LUNs, attach the LUNs to the host of the production center before the creation.

    • If the datastore is to be created based on NAS file systems, directly create a network file system-based (NFS-based) datastore.

  12. View the recovery plan, and record all removed VMs.
  13. Based on datastores created on 11, add all removed VMs in vCenter and start them.

  14. Log in to eReplication and manually refresh vCenter and storage devices at the production and DR centers, respectively.
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Updated: 2019-05-21

Document ID: EDOC1100075861

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