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OceanStor BCManager 6.5.0 eReplication User Guide 02

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Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
The System Does Not Respond Because the GaussDB Database Is Abnormal

The System Does Not Respond Because the GaussDB Database Is Abnormal

Symptom

After a user enters the user name and password on the eReplication login page and clicks Login, the user waits for a long time. After 50 seconds, a message is displayed indicating that the license has expired and the login page is displayed again, as shown in the following figure.

Possible Causes

GaussDB fails to invoke the fork process of the Linux operating system function library. As a result, eReplication cannot access the GaussDB database.

Procedure

  1. Use PuTTY to log in to the eReplication Server.

    • Template installation mode: log in to the eReplication Server as user DRManager. Run the su root command to switch to user root.
    • Software package installation mode: Log in to the eReplication Server as user root.
    NOTE:
    The default password of user DRManager is Huawei@CLOUD8. For the template installation mode, the default password of user root is Huawei@CLOUD8!.

  2. Run the /usr/local/gaussdb/bin/gsql -d LEGO -U GaussDB -p 6432 command to check whether the command output for entering a password is displayed.

    NOTE:
    It is recommended that you run the command for three times to ensure that the problem is consistent with that in the case.
    • If yes, contact Huawei technical support.
    • If no, perform 3.

  3. Run the ps –ef | grep gaussdb command to check whether there is a process whose status is <defunct>.



    • If yes, perform 4.
    • If no, contact Huawei technical support.

  4. Check whether the database is deployed in active/standby mode or HA mode. For details, see Querying the Deployment Mode Status and Service Information.

    • If yes, perform 5.
    • If no, perform 7.

  5. Log in to the standby eReplication Server, and perform 2 to check whether the command output for entering a password is displayed.

    • If yes, perform 6.
    • If no, contact Huawei technical support.

  6. Check the deployment mode of the database.

  7. Restart the database.

    1. Run the cd /opt/BCManager/Runtime/bin command to switch the directory.
    2. Run the sh shutdownSystem.sh command to shut down the eReplication Server.
    3. Run the sh startSystem.sh command to check whether the eReplication Server can be started.
      • If yes, perform 12.
      • If no, perform 8.

  8. Restart the OS.

    1. Run the reboot command to restart the OS.
    2. Run the sh startSystem.sh command to check whether the eReplication Server can be started.
      • If restarting the OS succeeds, perform 12.
      • If restarting the OS fails, perform 9.

  9. Check whether automatic backup is configured for the faulty eReplication Server.

    • If yes, perform 10.
    • If no, contact Huawei technical support.

  10. Reinstall the eReplication Server and prepare a VM that shares the same environment with the faulty eReplication Server. For details, see Installing the eReplication Server.
  11. Recover the configuration data. For details, see Restoring Configuration Data.
  12. Log in to the eReplication Server again. After the login is successful, view the home page of the system. If the login fails, contact Huawei technical support.
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Updated: 2019-05-21

Document ID: EDOC1100075861

Views: 18296

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