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OceanStor BCManager 6.5.0 eReplication User Guide 02

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What Can I Do If eReplication Nodes Become Faulty

What Can I Do If eReplication Nodes Become Faulty

Symptom

During the system running, if the following faults occur, follow instructions in this section to troubleshoot them.

  • When the eReplication node is faulty, restarting the management node cannot restore services.
  • In remote DR mode, the alarm indicating abnormal communication with the management server of the remote center is displayed.
  • In a HA cluster, a node failure will cause the operating system to be unable to start.

Possible Causes

  • The file system on the physical machine or VM where the management node resides is faulty.
  • eReplication malfunctions.

Fault Diagnosis

None

Procedure

  1. In a non-HA cluster:
    1. Install eReplication of the same version of a new physical server or VM. For details, see the OceanStor BCManager 6.5.0 eReplication Product Documentation.

      After installation, reconfigure eReplication's network and ensure its node name, IP address, and other information are the same as those of the replaced eReplication.

    2. Obtain the latest management data backup.

      Paths for storing backup files:

      • In automatic backup mode
        • Linux: /SFTP user/CloudComputing/DRBackup/eReplication management IP address/YYYY-MM-DD/Auto/ConfigData.zip
        • Windows: \CloudComputing\DRBackup\eReplication management IP address\YYYY-MM-DD\Auto\ConfigData.zip
      • In manual backup, they can be obtained from the local ConfigData.zip file.

    3. Import configuration data to the newly installed eReplication.

      NOTE:
      To import configuration data, data backups to be imported to eReplication at the production and DR sites must be of the same point in time, ensuring data consistency.

  2. HA cluster conditions:
    1. Install eReplication of the same version of a new physical server or VM. Set the time of the new physical server or VM to the same as that of the normal physical server or VM in the HA cluster. For details, see OceanStor BCManager 6.5.0 eReplication Product Document. Configure HA for the new physical server or VM by referring to Configuring a Deployment Mode and set it to be the standby server. (Do not start the system during this process.)
    2. If the arbitration service is configured on the original faulty node, configure the same service on the new physical server or VM. For details, see Configuring the Cloud Platform Quorum Service
    3. Re-configure HA for the normal physical server or VM in the HA cluster by referring to Configuring a Deployment Mode, and configure it as the active server. After configuration, restart the eReplication system as prompted by referring to Querying the Deployment Mode Status and Service Information.
    4. Start eReplication on the new physical server or VM by referring to Starting the eReplication Server. Confirm that it is the standby server by referring to Querying the Deployment Mode Status and Service Information.
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Updated: 2019-05-21

Document ID: EDOC1100075861

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