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OceanStor BCManager 6.5.0 eReplication User Guide 02

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Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
What Can I Do If the Agent Cannot Be Started After Its Default Port Being Occupied

What Can I Do If the Agent Cannot Be Started After Its Default Port Being Occupied

Symptom

The eReplication Agent fails to be started by using the script.

Possible Causes

The default port of the eReplication Agent is occupied by another process. Therefore, eReplication Agent cannot be started.

Procedure

  1. Find the process that occupies the default port.
    • UNIX-like operating system

      1. Run the netstat -ap | grep 59526 command. In the command output, the italic number string is the ID of the process to be queried.

        tcp 0 0 RH52-21.localdomain:59526 *:* LISTEN 26063/bin

      2. Run the following command to find the process corresponding to the ID.

        ps -ef | grep 26063

    • Windows

      1. Choose Start Run. Then run the cmd and netstat -aon | findstr "59526" commands. In the command output, the italic number string is the ID of the process to be queried.

        TCP [::1]:6100 [::1]:50266 ESTABLISHED 4788

        TCP [::1]:50266 [::1]:6100 ESTABLISHED 4052

      2. In the task manager, find the process corresponding to the ID.
  2. If the process queried can be stopped, stop the process and restart the eReplication Agent. Then go to 5. If the process cannot be stopped, go to 3.
  3. Reset the port number of the eReplication Agent.
    1. Select a free port based on the information obtained at 1 and change the value of PORT in the bin/nginx/conf/nginx.conf (UNIX-like operating system), and bin\nginx\conf\nginx.conf (Windows) file under the root directory of the eReplication Agent. For example, change 59526 to 60000.

    2. Save the change and start the eReplication Agent.
  4. On eReplication, change the discovery port of the host. On the menu bar, click Resources, select the site of the management server, click Host of the site node, locate the host whose information is to be changed, click Modify in the operation button area, and change the port number.

    NOTE:

    If this is the first time to discover the DR host, enter the new port number for discovery.

  5. Refresh the host.
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Updated: 2019-05-21

Document ID: EDOC1100075861

Views: 10332

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