No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Changing the Stack ID of S5700

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Changing the Stack ID of S5700

Changing the Stack ID of S5700

Introduction

This document describes the procedure for modifying stack IDs of member switches in a stack of S series fixed switches. This document applies to all stacks of S series fixed switches.

Prerequisites

After changing the stack IDs, you need to restart the switches to make the changes take effect, which will interrupt services. To minimize the impact on services, restart the switches in a specified period.

Initial Configuration

In Figure 1-1, the stack IDs of stack members are 3, 1, and 2 from top to bottom. These stack IDs need to be planned again based on the location to facilitate device management.

Figure 1-1 Networking diagram

View information about the stack members.

<Stack> display stack
Stack mode: Service-port                                                       
Stack topology type: Ring                                                        
Stack system MAC: 0018-82b1-6eb4                                                 
MAC switch delay time: 10 min                                                     
Stack reserved VLAN: 4093                                                        
Slot of the active management port: 3 
Slot Role        MAC address       Priority Device type 
------------------------------------------------------------- 
 3 Master      0018-82b1-6eb4 200          S5720-28X-LI-AC 
 1 Standby     0018-82b1-6eba 150          S5720-28X-LI-AC 
 2 Slave       0018-82b1-6ebb 150          S5720-28X-LI-AC

The stack IDs of stack members need to be changed. After the change, check whether the changes are correct based on the MAC addresses of the switches.

  • Change the stack ID from slot 3 to slot 1.
  • Change the stack ID from slot 1 to slot 2.
  • Change the stack ID from slot 2 to slot 3.

Renumber the Stack ID

  1. Shut down the uplink and downlink ports of the stack to isolate the stack from the network.

    <Stack> system-view 
    [Stack] interface gigabitethernet 3/0/8 
    [Stack-GigabitEthernet3/0/8] shutdown 
    [Stack-GigabitEthernet3/0/8] quit 
    [Stack] interface gigabitethernet 1/0/9 
    [Stack-GigabitEthernet1/0/9] shutdown 
    [Stack-GigabitEthernet1/0/9] quit 
    [Stack] interface gigabitethernet 2/0/5 
    [Stack-GigabitEthernet2/0/5] shutdown 
    [Stack-GigabitEthernet2/0/5] quit 
    [Stack] interface gigabitethernet 3/0/6 
    [Stack-GigabitEthernet3/0/6] shutdown 
    [Stack-GigabitEthernet3/0/6] quit

  2. After the stack IDs are changed, the configurations of the interfaces with the original stack IDs will be lost. Therefore, you need to perform the same configurations on the new interfaces before changing the stack IDs.

    For example: The configurations of the interfaces with the original stack IDs are as follows:

    # 
    interface GigabitEthernet3/0/6 
     description ToPC                                                                                                                    
     port link-type access                                                                                                               
     port default vlan 10 
    # 
    interface GigabitEthernet3/0/8 
     eth-trunk 10 
    # 
    interface GigabitEthernet1/0/9 
     eth-trunk 10 
    # 
    interface GigabitEthernet2/0/5 
     description ToIPPhone-01                                                                                                                    
     port link-type access                                                                                                               
     port default vlan 20 
    #     

    Change the configurations of these interfaces to the configurations of the interfaces with the new stack IDs.

    [Stack] interface gigabitethernet 1/0/6  // Correspond to GE3/0/6. 
    [Stack-GigabitEthernet1/0/6] description ToPC 
    [Stack-GigabitEthernet1/0/6] port link-type access 
    [Stack-GigabitEthernet1/0/6] port default vlan 10 
    [Stack-GigabitEthernet1/0/6] quit 
    [Stack] interface gigabitethernet 1/0/8  // Correspond to GE3/0/8. 
    [Stack-GigabitEthernet1/0/8] eth-trunk 10 
    [Stack-GigabitEthernet1/0/8] quit 
    [Stack] interface gigabitethernet 2/0/9  // Correspond to GE1/0/9. 
    [Stack-GigabitEthernet2/0/9] eth-trunk 10 
    [Stack-GigabitEthernet2/0/9] quit 
    [Stack] interface gigabitethernet 3/0/5  // Correspond to GE2/0/5. 
    [Stack-GigabitEthernet3/0/5] description ToIPPhone-01 
    [Stack-GigabitEthernet3/0/5] port link-type access 
    [Stack-GigabitEthernet3/0/5] port default vlan 20 
    [Stack-GigabitEthernet3/0/5] quit

  3. Change the stack IDs, save the configurations, and restart the switches.

    [Stack] stack slot 3 renumber 1 
    Info: The assigned slot ID already exists in the stack system.  
    Warning: All the configurations related to the slot ID will be lost after the slot ID is modified. 
    Do not frequently modify the slot ID because it will make the stack split. Continue? [Y/N]:y  
    Info: Stack configuration has been changed, and the device needs to restart to make the configuration effective. 
    [Stack] stack slot 1 renumber 2 
    Info: The assigned slot ID already exists in the stack system.  
    Warning: All the configurations related to the slot ID will be lost after the slot ID is modified. 
    Do not frequently modify the slot ID because it will make the stack split. Continue? [Y/N]:y  
    Info: Stack configuration has been changed, and the device needs to restart to make the configuration effective. 
    [Stack] stack slot 2 renumber 3 
    Info: The assigned slot ID already exists in the stack system.  
    Warning: All the configurations related to the slot ID will be lost after the slot ID is modified.
    Do not frequently modify the slot ID because it will make the stack split. Continue? [Y/N]:y 
    Info: Stack configuration has been changed, and the device needs to restart to make the configuration effective. 
    [Stack] quit 
    <Stack> save 
    The current configuration will be written to flash:/vrpcfg.zip. 
    Are you sure to continue?[Y/N]y   
    Now saving the current configuration to the slot 3.........    
    Save the configuration successfully.              
    Now saving the current configuration to the slot 1. 
    Save the configuration successfully.       
    Now saving the current configuration to the slot 2. 
    Save the configuration successfully.                  
    <Stack> reboot 
    Info: The system is now comparing the configuration, please wait...................  
    Info: If want to reboot with saving diagnostic information, input 'N' and then execute 'reboot save diagnostic-information'. 
    System will reboot! Continue?[Y/N]:y

  4. After the restart is complete, check whether the stack status, stack IDs, and interface configurations are correct. If the configurations on the interfaces are incorrect, reconfigure the interfaces.

    <Stack> display stack
    Stack mode: Service-port                                                       
    Stack topology type: Ring                                                        
    Stack system MAC: 0018-82b1-6eb4                                                 
    MAC switch delay time: 10 min                                                     
    Stack reserved VLAN: 4093                                                        
    Slot of the active management port: 1 
    Slot    Role        MAC address       Priority   Device type 
    ------------------------------------------------------------- 
        1   Master      0018-82b1-6eb4    200        S5720-28X-LI-AC 
        2   Standby     0018-82b1-6eba    150        S5720-28X-LI-AC 
        3   Slave       0018-82b1-6ebb    150        S5720-28X-LI-AC

  5. If the configurations are correct, enable the uplink and downlink ports of the stack.

    <Stack> system-view 
    [Stack] interface gigabitethernet 1/0/8 
    [Stack-GigabitEthernet1/0/8] undo shutdown 
    [Stack-GigabitEthernet1/0/8] quit 
    [Stack] interface gigabitethernet 2/0/9 
    [Stack-GigabitEthernet2/0/9] undo shutdown 
    [Stack-GigabitEthernet2/0/9] quit 
    [Stack] interface gigabitethernet 3/0/5 
    [Stack-GigabitEthernet3/0/5] undo shutdown 
    [Stack-GigabitEthernet3/0/5] quit 
    [Stack] interface gigabitethernet 1/0/6 
    [Stack-GigabitEthernet1/0/6] undo shutdown 
    [Stack-GigabitEthernet1/0/6] quit

Translation
Download
Updated: 2019-06-29

Document ID: EDOC1100088096

Views: 630

Downloads: 27

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next