Example for Configuring a Branch to Use 3G Cellular Interfaces for Internet Access and VoIP Communication
Networking Requirements
Because some branches are located in remote areas, it is difficult to deploy fixed networks. Enterprise branches need to use the 3G mode for Internet access and VoIP communication through the IMS network.
As shown in Figure 11-10, the branch uses the Router as the egress gateway and uses 3G cellular interfaces to connect to the Internet and IMS network through the 3G network.
The branch has obtained the following information from the carrier:
- User name and password: 3guser and YsHsjx_202206
- APN: DATANET
- Dialer number: *99#
Configuration Roadmap
You can use the multi-APN function of 3G cellular interfaces to implement data and VoIP communication.
The configuration roadmap is as follows:
# Configure the enterprise intranet and configure the Router to assign IP addresses to intranet users.
# Create two APN profiles. One profile corresponds to the APN connecting to the Internet, and the other corresponds to the APN connecting to the IMS network.
# Configure 3G cellular interfaces, configure a network connection mode, and enable the multi-APN function.
# Configure C-DCC on the two 3G interfaces and bind the APN profiles to the two interfaces.
# Configure NAT and specify the IP address of the 3G channel interface as the public IP address of the enterprise branch.
# Configure default routes and specify 3G channel interfaces as outbound interfaces so that traffic from the branch intranet is forwarded to the 3G network through the 3G channel interfaces.
Procedure
- Configure the enterprise intranet.
# Create VLAN 10 and add Ethernet2/0/0 to VLAN 10.
<Huawei> system-view
[Huawei] sysname Router
[Router] vlan 10
[Router-vlan10] quit
[Router] interface ethernet 2/0/0
[Router-Ethernet2/0/0] port link-type trunk
[Router-Ethernet2/0/0] port trunk allow-pass vlan 10
[Router-Ethernet2/0/0] quit
# Enable DHCP.
[Router] dhcp enable
# Create a global address pool.
[Router] ip pool 3gpool
[Router-ip-pool-3gpool] network 10.10.10.0 mask 255.255.255.0
[Router-ip-pool-3gpool] gateway-list 10.10.10.254
[Router-ip-pool-3gpool] quit
# Configure the interface to use the global address pool.
[Router] interface vlanif 10
[Router-Vlanif10] ip address 10.10.10.1 255.255.255.0
[Router-Vlanif10] dhcp select global
[Router-Vlanif10] quit
- Configure APN profiles.
# Configure an APN profile named datanet to connect to the Internet.
[Router] apn profile datanet
[Router-apn-profile-datanet] apn DATANET
[Router-apn-profile-datanet] user name 3guser password cipher YsHsjx_202206 authentication-mode auto
[Router-apn-profile-datanet] quit
# Configure an APN profile named voicenet to connect to the IMS network.
[Router] apn profile voicenet
[Router-apn-profile-voicenet] apn VOICENET
[Router-apn-profile-voicenet] quit
- Configure a 3G cellular interface.
# Configure a network connection mode.
[Router] interface cellular 0/0/0
[Router-Cellular0/0/0] mode wcdma wcdma-precedence
# Enable the multi-APN function on the 3G cellular interface.
[Router-Cellular0/0/0] multi-apn enable
[Router-Cellular0/0/0] quit
- Configure C-DCC on the 3G channel interface.
# Configure C-DCC on cellular0/0/0:1 and bind the APN profile datanet to cellular0/0/0:1.
[Router] interface cellular 0/0/0:1
[Router-Cellular0/0/0:1] ip address negotiate
[Router-Cellular0/0/0:1] dialer enable-circular
[Router-Cellular0/0/0:1] dialer number *99# autodial
[Router-Cellular0/0/0:1] apn-profile datanet
[Router-Cellular0/0/0:1] shutdown
[Router-Cellular0/0/0:1] undo shutdown
[Router-Cellular0/0/0:1] quit
# Configure C-DCC on cellular0/0/0:2 and bind the APN profile voicenet to cellular0/0/0:2.
[Router] interface cellular 0/0/0:2
[Router-Cellular0/0/0:2] ip address negotiate
[Router-Cellular0/0/0:2] dialer enable-circular
[Router-Cellular0/0/0:2] dialer number *99# autodial
[Router-Cellular0/0/0:2] apn-profile voicenet
[Router-Cellular0/0/0:2] shutdown
[Router-Cellular0/0/0:2] undo shutdown
[Router-Cellular0/0/0:2] quit
- Configure NAT.
[Router] acl number 3002 [Router-acl-adv-3002] rule 5 permit ip source 10.10.10.0 0.0.0.255 [Router-acl-adv-3002] quit [Router] interface cellular 0/0/0:1 [Router-Cellular0/0/0:1] nat outbound 3002 [Router-Cellular0/0/0:1] quit [Router] interface cellular 0/0/0:2 [Router-Cellular0/0/0:2] nat outbound 3002 [Router-Cellular0/0/0:2] quit
- Configure default routes and specify the 3G channel interfaces as the outbound interfaces.
[Router] ip route-static 0.0.0.0 0 cellular 0/0/0:1
[Router] ip route-static 0.0.0.0 0 cellular 0/0/0:2
- Verify the configuration.
# After the configuration is completed, traffic of the branch intranet is transmitted to the 3G network through 3G cellular interfaces and branch users can perform data and VoIP communication through 3G cellular interfaces.
Example
Configuration file of the Router
# sysname Router # vlan batch 10 # dhcp enable # acl number 3002 rule 5 permit ip source 10.10.10.0 0.0.0.255 # ip pool 3gpool gateway-list 10.10.10.254 network 10.10.10.0 mask 255.255.255.0 # interface Vlanif10 ip address 10.10.10.1 255.255.255.0 dhcp select global # interface Ethernet2/0/0 port link-type trunk port trunk allow-pass vlan 10 # interface Cellular0/0/0 link-protocol ppp multi-apn enable # interface Cellular0/0/0:1 link-protocol ppp dialer enable-circular apn-profile datanet dialer timer autodial 10 dialer number *99# autodial nat outbound 3002 ip address negotiate # interface Cellular0/0/0:2 dialer enable-circular apn-profile voicenet dialer timer autodial 10 dialer number *99# autodial nat outbound 3002 ip address negotiate # apn profile datanet user name 3guser password cipher %@%@9eCPJjmQR!gQxf6@q%.;,u5q%@%@ authentication-mode chap apn DATANET apn profile voicenet apn VOICENET # ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0:1 ip route-static 0.0.0.0 0.0.0.0 Cellular0/0/0:2 # return