LUN Information Failed to Be Updated After LUN Replacement
Symptom
After a LUN is replaced (the new LUN shares the same host ID as the original LUN), the information about the new LUN cannot be updated.
Root Cause
LUN information is not updated on the host.
Solution
Perform the following operations to remove or change the mapping of a LUN used by SUSE hosts:
- Before removing or changing LUN mapping on the storage system, stop all services running on the disk mapped by the LUN.
- On DeviceManager, unmap the LUN.
- Scan for LUNs on the host.
- Run the multipath –ll command on the host. Find and record the name of the multipath disk (mpathX) corresponding to the unmapped LUN and the physical path (sdX).
- Run the multipath -f mpathX command to delete the multipath disk identified in 4.
- Run the echo 1 > /sys/block/sdX/device/delete command to delete the physical path identified in 4.
- On DeviceManager, map a new LUN to the host.
- Scan for LUNs on the host and reconfigure services.
- If the host uses Huawei UltraPath, change LUN mappings by following instructions in the FAQ of the OceanStor UltraPath for XXX User Guide. XXX represents the OS, such as Linux.
- If the host cannot detect the LUN whose host LUN ID is 0, run the lsscsi command to check whether the drive letter has been occupied. If the drive letter has been occupied (an example is provided in the following figure), delete the invalid drive letter and scan again.