Example for Configuring an ICMP Test Instance
Networking Requirements
In Figure 6-31, SwitchA functions as an NQA client to test whether SwitchB is reachable.
Configuration Roadmap
The configuration roadmap is as follows:
- Perform the NQA ICMP test function to test whether the packet sent by SwitchA can reach SwitchB.
- Perform the NQA ICMP test to obtain the RTT of the packet.
Procedure
- Configure an IP address for SwitchA.
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan 100
[SwitchA-vlan100] quit
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid
[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface vlanif 100
[SwitchA-Vlanif100] ip address 10.1.1.1 24
[SwitchA-Vlanif100] quit
- Configure an IP address for SwitchB.
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan 100
[SwitchB-vlan100] quit
[SwitchB] interface gigabitethernet 1/0/1
[SwitchB-GigabitEthernet1/0/1] port link-type hybrid
[SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
[SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
[SwitchB-GigabitEthernet1/0/1] quit
[SwitchB] interface vlanif 100
[SwitchB-Vlanif100] ip address 10.1.1.2 24
[SwitchB-Vlanif100] quit
- Enable the NQA client and create an NQA ICMP test instance.
[SwitchA] nqa test-instance admin icmp
[SwitchA-nqa-admin-icmp] test-type icmp
[SwitchA-nqa-admin-icmp] destination-address ipv4 10.1.1.2
- Start the test instance.
[SwitchA-nqa-admin-icmp] start now
- Verify the configuration.
[SwitchA-nqa-admin-icmp] display nqa results test-instance admin icmp NQA entry(admin, icmp) :testflag is inactive ,testtype is icmp 1 . Test 1 result The test is finished Send operation times: 3 Receive response times: 3 Completion:success RTD OverThresholds number: 0 Attempts number:1 Drop operation number:0 Disconnect operation number:0 Operation timeout number:0 System busy operation number:0 Connection fail number:0 Operation sequence errors number:0 RTT Status errors number:0 Destination ip address:10.1.1.2 Min/Max/Average Completion Time: 3/125/44 Sum/Square-Sum Completion Time: 132/15650 Last Good Probe Time: 2014-11-28 13:55:52.5 Lost packet ratio: 0 %
Configuration Files
SwitchA configuration file
# sysname SwitchA # vlan batch 100 # interface Vlanif100 ip address 10.1.1.1 255.255.255.0 # interface GigabitEthernet1/0/1 port link-type hybrid port hybrid pvid vlan 100 port hybrid untagged vlan 100 # nqa test-instance admin icmp test-type icmp destination-address ipv4 10.1.1.2 # return
SwitchB configuration file
# sysname SwitchB # vlan batch 100 # interface Vlanif100 ip address 10.1.1.2 255.255.255.0 # interface GigabitEthernet1/0/1 port link-type hybrid port hybrid pvid vlan 100 port hybrid untagged vlan 100 # return