Example for Configuring an FTP Upload Test Instance
Networking Requirements
In Figure 6-29, the speed of uploading a file from SwitchA to an FTP server needs to be tested.
Configuration Roadmap
The configuration roadmap is as follows:
Configure Switch A as an NQA client as well as an FTP client. Create and start an FTP test instance on SwitchA to check whether SwitchA can set up a connection with the FTP server and to obtain the time taken by SwitchA to upload a file to the FTP server.
A user named user1 logs in to the FTP server by entering the password hello123 to upload a file with the size being 10 KB.
Procedure
- Configure SwitchB.
# Configure an IP address for SwitchB.
<HUAWEI> system-view
[HUAWEI] sysname SwitchB
[SwitchB] vlan 100
[SwitchB-vlan100] quit
[SwitchB] interface gigabitethernet 1/0/1
[SwitchB-GigabitEthernet1/0/1] port link-type hybrid
[SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
[SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
[SwitchB-GigabitEthernet1/0/1] quit
[SwitchB] interface vlanif 100
[SwitchB-Vlanif100] ip address 10.1.1.2 24
[SwitchB-Vlanif100] quit
# Configure SwitchB as the FTP server.
[SwitchB] ftp server enable
[SwitchB] aaa
[SwitchB-aaa] local-user user1 password irreversible-cipher hello123
[SwitchB-aaa] local-user user1 privilege level 15
[SwitchB-aaa] local-user user1 service-type ftp
[SwitchB-aaa] local-user user1 ftp-directory flash:/
[SwitchB-aaa] quit [SwitchB] quit
- Configure SwitchA.
# Configure an IP address for SwitchA.
<HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] vlan 100
[SwitchA-vlan100] quit
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid
[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface vlanif 100
[SwitchA-Vlanif100] ip address 10.1.1.1 24
[SwitchA-Vlanif100] quit
# Create an NQA FTP test on SwitchA and create a file of 10 KB for uploading.
[SwitchA] nqa test-instance admin ftp
[SwitchA-nqa-admin-ftp] test-type ftp
[SwitchA-nqa-admin-ftp] destination-address ipv4 10.1.1.2
[SwitchA-nqa-admin-ftp] source-address ipv4 10.1.1.1
[SwitchA-nqa-admin-ftp] ftp-operation put
[SwitchA-nqa-admin-ftp] ftp-username user1
[SwitchA-nqa-admin-ftp] ftp-password hello123
[SwitchA-nqa-admin-ftp] ftp-filesize 10
- Start the test instance.
[SwitchA-nqa-admin-ftp] start now
- Check the configuration.
# Check NQA test results on SwitchA.
[SwitchA-nqa-admin-ftp] display nqa results test-instance admin ftp NQA entry(admin, ftp) :testflag is inactive ,testtype is ftp 1 . Test 1 result The test is finished SendProbe:1 ResponseProbe:1 Completion:success RTD OverThresholds number: 0 MessageBodyOctetsSum: 10240 Stats errors number: 0 Operation timeout number: 0 System busy operation number:0 Drop operation number:0 Disconnect operation number: 0 CtrlConnTime Min/Max/Average: 657/657/657 DataConnTime Min/Max/Average: 500/500/500 SumTime Min/Max/Average: 1157/1157/1157 Average RTT:656 Lost packet ratio:0 %
# On SwitchB, you can view that a file named nqa-ftp-test.txt is added. Part of the file on the SwitchB is displayed.
<SwitchB> dir flash:
Directory of flash:/ 0 -rw- 331 Jul 06 2007 18:34:34 private-data.txt 1 -rw- 10,240 Jul 06 2007 18:37:06 nqa-ftp-test.txt 2,540 KB total (1,536 KB free)
Configuration Files
SwitchA configuration file
# sysname SwitchA # vlan batch 100 # interface Vlanif100 ip address 10.1.1.1 255.255.255.0 # interface GigabitEthernet1/0/1 port link-type hybrid port hybrid pvid vlan 100 port hybrid untagged vlan 100 # nqa test-instance admin ftp test-type ftp destination-address ipv4 10.1.1.2 source-address ipv4 10.1.1.1 ftp-filesize 10 ftp-username user1 ftp-password cipher %^%#z:zPAcsVG(dT)wOS=@vS-3gw!X4xn"*jP.FcU\zB%^%# ftp-operation put # return
SwitchB configuration file
# sysname SwitchB # FTP server enable # vlan batch 100 # aaa local-user user1 password irreversible-cipher $1a$a:zPAcsVG(dT)wOS=@vS-1gw!X3xn"*jP.FcU\zB$ local-user user1 privilege level 15 local-user user1 ftp-directory flash:/ local-user user1 service-type ftp # interface Vlanif100 ip address 10.1.1.2 255.255.255.0 # interface GigabitEthernet1/0/1 port link-type hybrid port hybrid pvid vlan 100 port hybrid untagged vlan 100 # return