PKI_1.3.6.1.4.1.2011.6.122.34.0.2.8 hwPKIGetCertFailLdap
Description
PKI/4/PKIGETCERTFAILLDAP: OID [oid] get certificate unsuccessfully with LDAP. (hwLdapIP=[ldapip], hwLdapPort=[ldapport], hwCertAttribute=[certattribute], hwCertDN=[certdn], hwLdapVersion=[ldapversion], hwCertSaveName=[certsavename])
The system failed to obtain the certificate through LDAP.
Attribute
Alarm ID | Alarm Severity | Alarm Type |
---|---|---|
1.3.6.1.4.1.2011.6.122.34.0.2.8 | Warning | communicationsAlarm |
Parameters
Name | Meaning |
---|---|
oid | Indicates the MIB object ID of the alarm. |
ldapip | Indicates the IP address of the LDAP server. |
ldapport | Indicates the port number of the LDAP server. |
certattribute | Indicates the attribute of the certificate. |
certdn | Indicates the DN of the certificate. |
ldapversion | Indicates the version of the LDAP server. |
certsavename | Indicates the name of the saved certificate file. |
Possible Causes
- There is no reachable route between the device and LDAP server.
- The PKI configurations of the device and LDAP server are incorrect.
- The LDAP server is faulty.
Procedure
- Run the ping command to check whether there is a reachable route between the device and LDAP server.
If not, check the route and link to ensure that there is a reachable route between the device and LDAP server.
- Check whether the PKI configurations of the device and LDAP server are correct. The PKI configurations include the LDAP server IP address, port, and version.
If not, ensure that the PKI configurations are correct.
- Check whether the LDAP server is working properly.
If not, ensure that the LDAP server is working properly.
- Collect alarm and configuration information, and contact technical support personnel.