Failed to Open the Java Integrated Remote Console
Symptom
Symptom |
Possible Causes |
---|---|
The Java Integrated Remote Console cannot be opened. |
|
Solution
- Check whether the JRE is properly installed.
The iBMC supports AdoptOpenJDK 8 JRE and AdoptOpenJDK 11 JRE.
- If the JRE version is correct, contact technical support.
- If the JRE version is incorrect, go to 2.
- Download the JRE binary package matching the client OS from the official AdoptOpenJDK website.
- Install AdoptOpenJDK.
- Manually configure the JAVA_HOME and PATH environment variables after decompressing the package.
- Download IcedTea Web from the official AdoptOpenJDK website, decompress it, and configure the bin folder to the PATH environment variable.
- Open the Java Integrated Remote Console.
During this process, the .jnlp file is automatically downloaded.
- Open the .jnlp file.
- If the client uses Linux or Windows CLI, switch to the directory where .jnlp is located, and run javaws kvm.jnlp.
- If the client uses GUI, locate the .jnlp file, right-click the file and choose javaws. If javaws is not available in the short-cut menu, go to the bin folder in the IcedTea Web installation directory.