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Knowledge Base

Alarms on the iManager N2000 clients are not being acknowledged.

Publication Date:  2012-07-25  |   Views:  113  |   Downloads:  0  |   Author:  Fahad Shaikh  |   Document ID:  EKB0000373819

Contents

Issue Description

Alarms on the N2000 clients were not being acknowledged successfully due to memory buffer became full.
Server's version is: SunFire V440
OS 5.8

Alarm Information

When we acknowledge the alarms, a window appears that allocated memory against Database named "EnpowerDB" is full and cannot save further data.

Handling Process

-First of all, Query the Database Status which enables you to get the database occupancy, for the database "EnpowerDB” it was fully occupied.
-Tried to expand the database, which adds the additional memory to the existing memory, in order to save more data.(but it was failed because the operation didn’t complete successfully).
-Next step was to "Clear the Database", which allows to dump alarm history data to a file.  
-Still the alarms were not being acknowledged successfully.
-Logged out the NMS client and then logged in.
-Alarms are now being acknowledged successfully.
-Used below mentioned commands to truncate the database.
#isql  -SN2000DBServer �Usa �Pxxxx   (where xxx is the password of sa)
1>use EnpowerDB
2>go
3>truncate table tbl_EnpHistoryDataTab
4>go
-After doing this activity, used sysmonitor to check the EnpowerDB space.
-Now, the database had enough memory to save the acknowledged alarms.

Root Cause

Database "EnpowerDB" present at N2000 server, which stores the "Environment monitoring data" became full  and was running at 100% of its capacity.

Suggestions

In order to maintain the working of Server and clients normally, there must be a dumping policy (either automatic or manually) to log the data to a file, so that the database will not become full and the system works normally.