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Knowledge Base

Colombia - AR29 - SIP Protocol, SoftSwitch answer with 400 Bad Request message

Publication Date:  2012-07-27  |   Views:  8  |   Downloads:  0  |   Author:  William Francisco Galindo  |   Document ID:  EKB0000387977

Contents

Issue Description

After sending INVITE message from AR29 router to SoftSwitch, a message 400 Bad Request is received.

Alarm Information

*Mar  9 17:49:45:114 2009 TELMEX_1 SIP/7/VOICE:
NetWork--->Stack:
SIP/2.0 400 Bad Request
Via: SIP/2.0/UDP 10.8.255.185:5060;branch=z9hG4bK483e096cdde
Call-ID: d4978d4af4aeeb48dde91404483e096c8@10.8.255.185
From: <sip:7559874@10.8.255.185:5060>;tag=483e096c
To: <sip:6069606@172.31.239.100:5060>;tag=b45a85c3
CSeq: 1 INVITE
Content-Length: 0

Handling Process

Upgrade to VRP520-R1718.

Root Cause

After the AR29 Router sends INVITE message, the SoftSwitch rejects with a 400 Bad Request, but has no root cause. So we have to guess the reason for rejection (why SoftSwitch sending the 400 message) in the router, but if you want know the root cause, you need to ask SoftSwitch. 
We compare successful INVITE message (Release 1718 version) with unsuccessful INVITE message (Release 1618P16 version), and find only difference: The newest version (Release 1718) support keep live with OPTION message, and old version (Release 1618P16) does not support it. The different points in INVITE message have:  The newest version adds "OPTIONS" field in Allow Head, and add "timer" field behind "100rel" field in Supported Head.
So we think the reason for rejection on SoftSwitch maybe: The SoftSwitch need use OPTIONS message for keep live if the router have no this function, it will reject the call.

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