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Knowledge Base

FAQ-How handle client prompt the client type not exist when the client login

Publication Date:  2019-07-05  |   Views:  176  |   Downloads:  0  |   Author:  Zhou Feng  |   Document ID:  EKB0000427545

Contents

Issue Description

Q:
How handle client prompt the client type not exist when the client login.

Alarm Information

the client type not exist .

Handling Process

Step 1     
Check server/log/iMAPMdp_p2_***.log ,
find Create Task: CmdCode: 1025 (SS_USER_LOGIN) BEGIN,
ClientType:(2000),UserLogin: UserName(admin),IP(****),
If the value is 2000,it's correct ,go to step 2,or check the client configuration file.
BMS configuration file:client/style/productstyte/conf/security/SecurityConfig.xml
Platform configuration file:client/style/defaultstyle/conf/security/SecurityConfig.xml
<AREADESC areaname="CLIENT_TYPE">
        <DESC descname="CLIENTTYPEINFO">
            <PARAS>
                <PARA name="clienttype" value="2000"/>                
            </PARAS>
        </DESC>
    </AREADESC>
Step 2     
Check if database has this record.
use SecurityDB
go
select * from tbl_ClientType where ClientType=2000

Root Cause

1.Database SecurityDB..tbl_ClientType  no such this client type.
2.The configure file of client was broken.

Suggestions

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