No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

FAQ How to fix RIP route update using sub IP in AR4945

Publication Date:  2012-07-25  |   Views:  284  |   Downloads:  0  |   Author:  Chowdhury Rahman (C00738260)  |   Document ID:  EKB0000567748

Contents

Issue Description

Let us concider a senerio where a Huawei AR4945 Router is replacing a Huawei AR2811 device
which is running RIP as the routing protocol and has sub ip that is connected with the Third_party_device.

The existing topology is given below.

SCO---link---AR2811---link---Third_party_device

and the config of the AR2811 is like below.

AR2811
#
interface Ethernet0/0.15
 ip address 10.64.1.58 255.255.255.252
 vlan-type dot1q vid 15
#
interface Ethernet0/0.22
 ip address 172.20.16.14 255.255.255.248
 ip address 172.20.16.22 255.255.255.248 sub
 ip address 172.20.16.30 255.255.255.248 sub
 ip address 172.20.16.38 255.255.255.248 sub
 rip version 2 multicast
 vlan-type dot1q vid 22
#
interface Ethernet0/0.23
 ip address 172.20.17.14 255.255.255.248
 ip address 172.20.17.22 255.255.255.248 sub
 ip address 172.20.17.30 255.255.255.248 sub
 ip address 172.20.17.38 255.255.255.248 sub
 rip version 2 multicast
 vlan-type dot1q vid 23
#
rip
 network 172.20.0.0
 import-route ospf 100
#

And hence by logical choice the replace toplology would be.
The existing topology is given below.

SCO---link---AR4945---link---Third_party_device

and the config of the new AR4945 is like below.

AR4945
#
interface GigabitEthernet0/0.15
 vlan-type dot1q vid 15
 ip address 10.64.1.58 255.255.255.252
#
interface GigabitEthernet0/0.22
 vlan-type dot1q vid 22
 ip address 172.20.16.14 255.255.255.248
 ip address 172.20.16.22 255.255.255.248 sub
 ip address 172.20.16.30 255.255.255.248 sub
 ip address 172.20.16.38 255.255.255.248 sub
 rip version 2 multicast
#
interface GigabitEthernet0/0.23
 vlan-type dot1q vid 23
 ip address 172.20.17.14 255.255.255.248
 ip address 172.20.17.22 255.255.255.248 sub
 ip address 172.20.17.30 255.255.255.248 sub
 ip address 172.20.17.38 255.255.255.248 sub
 rip version 2 multicast
#
rip 1
 network 172.20.0.0
 import-route ospf 100
#


Alarm Information

After relpacing the old device with new one we find there is a routing table mismatch.

Routing Table output before replacing.

<Kachpur_Alc_DCN_Router>dis ip routing-table
 Routing Table: public net
Destination/Mask   Protocol Pre  Cost        Nexthop         Interface
--[output ommitied]--
10.64.1.9/32       RIP      100  2           172.20.16.9     Ethernet0/0.22
                                             172.20.17.9     Ethernet0/0.23
10.64.1.10/32      RIP      100  2           172.20.16.10    Ethernet0/0.22
                                             172.20.17.10    Ethernet0/0.23
10.64.1.11/32      RIP      100  2           172.20.16.10    Ethernet0/0.22
                                             172.20.17.10    Ethernet0/0.23
10.64.1.14/32      RIP      100  2           172.20.16.10    Ethernet0/0.22
                                             172.20.17.10    Ethernet0/0.23
10.64.1.17/32      RIP      100  2           172.20.16.17    Ethernet0/0.22
                                             172.20.17.17    Ethernet0/0.23
10.64.1.18/32      RIP      100  2           172.20.16.18    Ethernet0/0.22
                                             172.20.17.18    Ethernet0/0.23
10.64.1.19/32      RIP      100  2           172.20.16.18    Ethernet0/0.22
                                             172.20.17.18    Ethernet0/0.23
10.64.1.22/32      RIP      100  2           172.20.16.18    Ethernet0/0.22
                                             172.20.17.18    Ethernet0/0.23
10.64.1.25/32      RIP      100  2           172.20.16.25    Ethernet0/0.22
                                             172.20.17.25    Ethernet0/0.23
10.64.1.26/32      RIP      100  2           172.20.16.26    Ethernet0/0.22
                                             172.20.17.26    Ethernet0/0.23
10.64.1.27/32      RIP      100  2           172.20.16.25    Ethernet0/0.22
                                             172.20.17.25    Ethernet0/0.23
10.64.1.30/32      RIP      100  2           172.20.16.25    Ethernet0/0.22
                                             172.20.17.25    Ethernet0/0.23
10.64.1.33/32      RIP      100  2           172.20.16.33    Ethernet0/0.22
                                             172.20.17.33    Ethernet0/0.23
10.64.1.34/32      RIP      100  2           172.20.16.34    Ethernet0/0.22
                                             172.20.17.34    Ethernet0/0.23
10.64.1.35/32      RIP      100  2           172.20.16.33    Ethernet0/0.22
                                             172.20.17.33    Ethernet0/0.23
10.64.1.38/32      RIP      100  2           172.20.16.33    Ethernet0/0.22
                                             172.20.17.33    Ethernet0/0.23


Routing Table output after replacing.

<CE_ALC_DCN_KACHPUR_AR4945>dis ip routing-table
Routing Tables: Public
 Destinations : 116 Routes : 120

Destination/Mask    Proto  Pre  Cost         NextHop         Interface
--[output ommitied]--
10.64.1.9/32        RIP    100  2            172.20.16.9     GE0/0.22
                    RIP    100  2            172.20.17.9     GE0/0.23
10.64.1.10/32       RIP    100  2            172.20.16.10    GE0/0.22
                    RIP    100  2            172.20.17.10    GE0/0.23
10.64.1.11/32       RIP    100  2            172.20.16.10    GE0/0.22
                    RIP    100  2            172.20.17.10    GE0/0.23
10.64.1.14/32       RIP    100  2            172.20.16.10    GE0/0.22
                    RIP    100  2            172.20.17.10    GE0/0.23


Handling Process

Because the RIP protocol is using the main interface as the source of RIP packet, so if you using another new ip address, this ip address maybe not in the same network with opposite interface, so maybe the opposite interface can't identify the new RIP packet. So to solve the problem we need to config the AR4945 router the following way.

#
interface GigabitEthernet0/0.15
 vlan-type dot1q vid 15
 ip address 10.64.1.58 255.255.255.252
#
interface GigabitEthernet0/0.22
 vlan-type dot1q vid 22
 ip address 172.20.16.14 255.255.255.0
 ip address 172.20.16.22 255.255.255.248 sub
 ip address 172.20.16.30 255.255.255.248 sub
 ip address 172.20.16.38 255.255.255.248 sub
 rip version 2 multicast
#
interface GigabitEthernet0/0.23
 vlan-type dot1q vid 23
 ip address 172.20.17.14 255.255.255.0
 ip address 172.20.17.22 255.255.255.248 sub
 ip address 172.20.17.30 255.255.255.248 sub
 ip address 172.20.17.38 255.255.255.248 sub
 rip version 2 multicast
#
rip 1
version 2
network 172.20.0.0
filter-policy ip-prefix test export
import-route static cost 0
#
#
ip ip-prefix test index 10 deny 172.20.16.0 24
ip ip-prefix test index 20 deny 172.20.17.0 24
ip ip-prefix test index 30 permit 0.0.0.0 0 less-equal 32
#
ip route-static 172.20.16.14 255.255.255.248 172.20.16.14
ip route-static 172.20.16.22 255.255.255.248 172.20.16.22
ip route-static 172.20.16.30 255.255.255.248 172.20.16.30
ip route-static 172.20.16.38 255.255.255.248 172.20.16.38
ip route-static 172.20.17.14 255.255.255.248 172.20.17.14
ip route-static 172.20.17.22 255.255.255.248 172.20.17.22
ip route-static 172.20.17.30 255.255.255.248 172.20.17.30
ip route-static 172.20.17.38 255.255.255.248 172.20.17.38
#


Root Cause

From the routing table out put we can find that in the new router the routing updates are all from the main IP addresses. In fact this is the root cause for this fault. WIth AR4945 routers the RIP routing protocol only excanges RIP routing update
with the main IP only.

Suggestions

Once the configuration is change is this process the RIP protocol will exchange all the routes.
And all the routes will be available in the routing table.