No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

OSPF peer flapping continuously

Publication Date:  2013-05-27  |   Views:  311  |   Downloads:  0  |   Author:  SU1000965009  |   Document ID:  EKB1000028759

Contents

Issue Description

As the project requirement, we have installed two (2) AR router in two cities. The communication link one is E1 and another is Internet. For exchange the private data, we implement GRE tunnel and want to use OSPF routing protocol. When we UP the GRE tunnel, we have observe the OSPF state continually change (UP & Down). The tunnel status is UP & we able to ping each other interface during this OSPF state change time.

One site tunnel configuration is as below:

interface Tunnel0
description CTG_AR29-TO-DHK_AR_29_VIA_E1
ip address 192.168.7.118 255.255.255.252
source 192.168.25.1
destination 192.168.25.2
ospf cost 10
ospf network-type p2p
#
interface Tunnel1
description CTG_AR29-TO-DHK_AR29_VIA_Internet
ip address 192.168.7.114 255.255.255.252
source 180.234.128.17
destination 180.234.0.165
ospf cost 50
ospf network-type p2p

OSPF configuration :
[CTG_AR29-ospf-1]dis this
#
ospf 1
area 0.0.0.0
network 192.168.7.116 0.0.0.3
network 192.168.7.112 0.0.0.3
network 172.16.65.0 0.0.0.255
network 172.16.64.0 0.0.0.255

The proper static route is also configuring. But the OSPF is not stable.
 

Alarm Information

The OSPF state change log is as below:


%May 10 14:24:37:571 2013 CTG_AR29 IFNET/4/LINK UPDOWN:
Tunnel1: link status is DOWN
%May 10 14:24:37:572 2013 CTG_AR29 IFNET/4/UPDOWN:
Line protocol on the interface Tunnel1 is DOWN
%May 10 14:24:37:572 2013 CTG_AR29 RM/3/RMLOG:OSPF-NBRCHANGE: Process 1, Neighbo
r 192.168.7.113(Tunnel1) from Full to Down
%May 10 14:24:47:557 2013 CTG_AR29 IFNET/4/LINK UPDOWN:
Tunnel1: link status is UP
%May 10 14:24:47:557 2013 CTG_AR29 IFNET/4/UPDOWN:
Line protocol on the interface Tunnel1 is UP
%May 10 14:24:56:264 2013 CTG_AR29 RM/3/RMLOG:OSPF-NBRCHANGE: Process 1, Neighbo
r 192.168.7.113(Tunnel1) from Loading to Full
%May 10 14:25:12:571 2013 CTG_AR29 IFNET/4/LINK UPDOWN:
Tunnel1: link status is DOWN
%May 10 14:25:12:572 2013 CTG_AR29 IFNET/4/UPDOWN:
Line protocol on the interface Tunnel1 is DOWN
%May 10 14:25:12:572 2013 CTG_AR29 RM/3/RMLOG:OSPF-NBRCHANGE: Process 1, Neighbo
r 192.168.7.113(Tunnel1) from Full to Down
%May 10 14:25:22:557 2013 CTG_AR29 IFNET/4/LINK UPDOWN:
Tunnel1: link status is UP
%May 10 14:25:22:557 2013 CTG_AR29 IFNET/4/UPDOWN:
Line protocol on the interface Tunnel1 is UP
%May 10 14:25:29:265 2013 CTG_AR29 RM/3/RMLOG:OSPF-NBRCHANGE: Process 1, Neighbo
r 192.168.7.113(Tunnel1) from Loading to Full
..

Handling Process

To prevent the OSPF routing information from being received by routers in a network segment and forbid the AR29 router to receive the routing update information that is advertised by other routers in the network segment, we use the silent-interface command to suppress the interface to receive or send the OSPF packets.

So, our final OSPF configuration is as below:

ospf 1
silent-interface all
undo silent-interface Tunnel1
undo silent-interface Tunnel0
area 0.0.0.0
network 192.168.7.116 0.0.0.3
network 192.168.7.112 0.0.0.3
network 172.16.65.0 0.0.0.255
network 172.16.64.0 0.0.0.255

After this we have found stable OSPF peer state i.e FULL. Our problem is resolved.

Root Cause

From the debug log of OSPF, this has been observe that, too much OSPF packet is transmit over all the physical link and tunnel interface. After OSPF reach in FULL state, receive one new OSPF packet, it calculate the SPF then the state is change and this process is continue . So the OSPF peer state continuously up and down.

Suggestions

For further analysis please  contact Huawei Technical support peronel