No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

Can not remove lun from ISM

Publication Date:  2013-07-29  |   Views:  217  |   Downloads:  0  |   Author:  SU1000781244  |   Document ID:  EKB1000031797

Contents

Issue Description

Can not remove one lun, There are no mappings to this luns.  RAID 5.

Alarm Information

Alarm in ISM:
"Data for the LUN is to be processed inside the system, Please try again later"

Handling Process

Try to delete the lun in CLI mode.
Level:
Administrator level.
Run the PuTTY software and the PuTTY Configuration dialog box is displayed,
Enter the IP address of the management network port in Specify your connection by host
The initial user name of the system administrator is admin. The initial password is
123456.
Function
The command deletelun is used to delete a LUN.
Format
deletelun [ -f ] -i LUN ID
Parameters
Keyword and Value Description Default Value

-f When you delete a LUN, you
do not need to enter the
confirmation information.

-i LUN ID The LUN ID. The value
ranges from 0 to 511.

Modes
Normal mode.

Example

Delete LUN 21.

OceanStor: admin> deletelun -f -i 21

Before deleting the LUN, make sure that the LUN has not request on it.
Are you sure you want to delete the LUN(y/n)?y




Root Cause

ISM doesn't work properly;
The product version is V100R005C02, and it's a very old version and may leads to several problems.
The root cause in this version  is a bug -the initiator hang up I/O. 

Suggestions

IF doesn't work with CLI mode and you recive below information :

admin:/>deletelun -i 21
Are you sure to delete?(y/n)
y
Error: Data for the LUN is to be processed inside the system. Please try again later.
admin:/>

Try to make an update if you can. If you want to reboot your  system just in mentenance time  follow the below steps :


1 Temporary solution:
Reboot storage.  After offline all customer services, login controller A through SSH, input resetsys.
Or input reboot on one controller, after restored then input reboot on the other controller. (in debug mode) (The initial user name of the system administrator is admin. The initial password is 123456. Input debug and initial password 654321 and we can login to debug mode)

2 Final solution:
Upgrade system to  last version (V100R005C02SPC011(1.04.05.131.T02)in my case)   through ISM.