Issue Description
When some users login by WI, they got an error stating 'WIN7-DG is currently unavailable. Try reconnecting and, if the problem persists contact your administrator'
Handling Process
Firstly we confirmed that the network was available from Thin client to VM.
Secondly we confirmed that there were enough VMs in desktop group.
Thirdly we confirmed that there were enough and available citrix license in License server.
Later we checked and found that customer used a dynamic pool desktop group in FusionAccess portal. In dynamic pool desktop group, any user in user group can randomly login any VM in corresponding dynamic pool. However, when one user login one VM, if he didn't log off when he left, other users would not login this VM.
We checked status of all VMs in dynamic pool desktop group in FusionAccess portal. We found status of some VMs were disconnected. If one user didn't log off when he left, status of corresponding would become VM disconnected, other users would not login this VM, Only other users could login this VM when it was idle status.
Root Cause
Firstly we need confirm whether the network was available from Thin client to VM.
Secondly we need confirm whether there were enough VMs in desktop group.
Thirdly we need confirm whether there were enough and available citrix license in License server.
Suggestions
We should configure overtime in DDC server. For example, you cnfigured overtime of 1 hour. If one user don’t log off when he leave, it is going to become disconnected status , however , after 1 hour it is going to become idle status, other users are going to login successfully.