No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

BFD Configuration Issues

Publication Date:  2014-03-11  |   Views:  865  |   Downloads:  0  |   Author:  SU1001428654  |   Document ID:  EKB1000040504

Contents

Issue Description

trying to configure Static BFD between Huawei AR200(V200R003C01SPC900) and Cisco 2900 series Device but BFD state is showing Down and Link is UP, first please state whether Huawei BFD can work with Cisco device, and then refer below configuration of both Ends .

Below is detailed Configuration and their Output status,


****** Cisco Router Configuration ******

interface GigabitEthernet0/2.709
description *** Branch Link ***
encapsulation dot1Q 709
ip address 192.168.1.1 255.255.255.252
bfd interval 500 min_rx 500 multiplier 5
!
ip route static bfd GigabitEthernet0/2.709 192.168.1.2
ip route 10.1.1.0 255.255.255.0 GigabitEthernet0/2.709 192.168.1.2 name Branch_Link

Cisco Router#sh bfd neighbors

NeighAddr                         LD/RD    RH/RS     State     Int
192.168.1.2                    16/0     Down      Down      Gi0/2.709






****** Huawei Router Configuration ******

Huawei Router : Version 5.120 (AR200 V200R003C01SPC900)


interface Ethernet0/0/8
ip address 192.168.1.2 255.255.255.252

#
bfd abc bind peer-ip 192.168.1.1 interface Ethernet0/0/8 source-ip 192.168.1.2
discriminator local 2
discriminator remote 1
detect-multiplier 5
min-tx-interval 500
min-rx-interval 500
commit
#
ip route-static 10.1.2.0 255.255.255.0 192.168.1.1 track bfd-session abc
!

Alarm Information

none

Handling Process

 try to change the configuration from Huawei side by using Dynamic BFD session and check if the BFD session can be built correctly

****** Huawei Router Configuration ******

Huawei Router : Version 5.120 (AR200 V200R003C01SPC900)


interface Ethernet0/0/8
ip address 192.168.1.2 255.255.255.252

#
bfd abc bind peer-ip 192.168.1.1 interface Ethernet0/0/8 source-ip 192.168.1.2 auto    ---- add this command
discriminator local 2                      ----delete this command
discriminator remote 1                  ----delete this command
detect-multiplier 5
min-tx-interval 500
min-rx-interval 500
commit
#
ip route-static 10.1.2.0 255.255.255.0 192.168.1.1 track bfd-session abc

after this revision , the problem has been resolved .

Root Cause

through checking the configuration and BFD session information 

[Huawei] all
--------------------------------------------------------------------------------
Local Remote     PeerIpAddr      State     Type        InterfaceName
--------------------------------------------------------------------------------
2     1          192.168.1.1  Down      S_IP_IF     Ethernet0/0/8
--------------------------------------------------------------------------------
     Total UP/DOWN Session Number : 0/1


[Huawei_Router]display bfd session all verbose

--------------------------------------------------------------------------------
Session MIndex : 66        (One Hop) State : Down      Name : abc
--------------------------------------------------------------------------------
  Local Discriminator    : 2                Remote Discriminator   : 1
  Session Detect Mode    : Asynchronous Mode Without Echo Function
  BFD Bind Type          : Interface(Ethernet0/0/8)
  Bind Session Type      : Static
  Bind Peer IP Address   : 192.168.1.1
  NextHop Ip Address     : 192.168.1.1
  Bind Interface         : Ethernet0/0/8
  Bind Source IP Address : 192.168.1.2
  FSM Board Id           : 0                TOS-EXP                : 7
  Min Tx Interval (ms)   : 500              Min Rx Interval (ms)   : 500
  Actual Tx Interval (ms): 12000            Actual Rx Interval (ms): 12000
  Local Detect Multi     : 5                Detect Interval (ms)   : -
  Echo Passive           : Disable          Acl Number             : -
  Destination Port       : 3784             TTL                    : 255
  Proc Interface Status  : Disable          Process PST            : Disable
  WTR Interval (ms)      : -
  Active Multi           : -
  Last Local Diagnostic  : No Diagnostic
  Bind Application       : No Application Bind
  Session TX TmrID       : 269              Session Detect TmrID   : -
  Session Init TmrID     : -                Session WTR TmrID      : -
  Session Echo Tx TmrID  : -
  PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
  Session Description    : -
--------------------------------------------------------------------------------

     Total UP/DOWN Session Number : 0/1

the physical link is up , but BFD session is down ,checking the configuration between two sides , and found

****** Cisco Router Configuration ******

interface GigabitEthernet0/2.709
description *** Branch Link ***
encapsulation dot1Q 709
ip address 192.168.1.1 255.255.255.252
bfd interval 500 min_rx 500 multiplier 5
!
ip route static bfd GigabitEthernet0/2.709 192.168.1.2
ip route 10.1.1.0 255.255.255.0 GigabitEthernet0/2.709 192.168.1.2 name Branch_Link
For Cisco side , there’s no any configuration about the parameter of “discriminator” ,  guess Cisco use the dynamic BFD session by default , and regarding Huawei side , the static BFD session is being used now ,  it’s caused by that probably . 

Suggestions

In common , Cisco router will adopt dynamic way to create BFD session , So we need to adopt corresponding way to configure our AR router , otherwise the BFD session could not be built correctly . And If we met some other vendors devices when we're configuring BFD , pay more attention to check and compare the configuraiton firstly , confirm which BFD session way they're using currently , then change the configuration to be consistent with the other side .