No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

MPLS L2VPN VLL , VC down issue

Publication Date:  2019-07-17  |   Views:  459  |   Downloads:  0  |   Author:  SU1001428654  |   Document ID:  EKB1000047791

Contents

Issue Description

when configuring Martini scenario in MPLS L2VPN VLL , the status of interface , PW , AC is up , but the status of VC always is down.


Alarm Information

none

Handling Process


upload corresponding MPLS L2VPN license and activate on AR2240 , reset mpls process , found VLL became working fine.


Root Cause

when we configure martini scenario in MPLS L2VPN VLL , if the martini VLL can't be up .

1. check if the encapsulation on both sides is consistent , if MTU is consistent.
2. check if the VC ID on both sides is consistent.
3. check if the configuration of "control word" is consistent.

S7506 configuration :

<shengting_s7506e>dis cu         //7506e
#
version 5.20, Release 6616P01
#
sysname shengting_s7506e
#
domain default enable system
#
 ssh server enable
#
switch-mode standard-routing
switch-mode normal slot 2
#
mpls lsr-id 15.185.254.2
#
vlan 1
#
vlan 44 to 69
#
vlan 100
#
vlan 1000
#
mpls
lsp-trigger all
#
l2vpn
mpls l2vpn reserve vlan 1818
mpls l2vpn
#
mpls ldp
#
mpls ldp remote-peer baisha
remote-ip 15.184.254.18
#
mpls ldp remote-peer baoting
remote-ip 15.184.254.19
#
...
#
interface Vlan-interface100
ip address 15.184.253.253 255.255.255.252                                           //与防火墙FW1000互联地址
#             
interface Vlan-interface1000
ip address 10.184.250.2 255.255.255.252                                                 //与公安网互联地址
mpls
mpls ldp
#
interface GigabitEthernet2/0/1
port link-mode bridge
port access vlan 1000
#
interface GigabitEthernet2/0/2
port link-mode bridge
#
....
#
interface GigabitEthernet2/0/24
port link-mode bridge
port access vlan 1000
#
interface M-Ethernet0/0/0
#
ip route-static 15.184.0.0 255.255.0.0 15.184.253.254
ip route-static 15.184.254.1 255.255.255.255 10.184.250.1
ip route-static 15.184.254.3 255.255.255.255 10.184.250.1
...
ip route-static 15.185.0.0 255.255.0.0 10.184.250.1
#
load xml-configuration
#
user-interface aux 0 1
user-interface vty 0 4
authentication-mode scheme
protocol inbound telnet
user-interface vty 5 15
#
return        


check all configuration related L2VPN , there's no configuration wrong , check if VLL function needs license to support . found there's no any license activating on AR2240 by using "dis license"

check the product doc of AR2240 , found there's some instruction below :

The L2VPN function is used with a license. To use the L2VPN function, apply for and purchase the following license from the Huawei local office:
AR1200 series: AR1200 Value-Added Data Package
AR2200 series: AR2200 Value-Added Data Package
AR3200 series: AR3200 Value-Added Data Package
The default VLAN does not support VLL.

doubts it likely to be a license issue

Suggestions

when we configure martini scenario in MPLS L2VPN VLL , the first thing we should check is if the corresponding license has been activated on device , if so , we can go ahead to do other troubleshooting . Following the step can avoid taking an indirect route.