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Knowledge Base

One-way call issue due to wrong next hop in AR2200

Publication Date:  2019-07-17  |   Views:  308  |   Downloads:  0  |   Author:  SU1001784671  |   Document ID:  EKB1000049411

Contents

Issue Description

A customer configured an AR to connect to IMS network using SIP AT0 trunk. After he finished the configuration, the SIP AT0 trunk can register to IMS network, and he can make the outgoing call incoming call, but there was a one-way call issue. He can hear the voice from other end, but the other end can’t hear his voice.
This is the topology:

In the topology, if the customer called from the phone 901455 connecting to AR to the remote phone 232505, he can hear the voice from other end, but the other end can’t hear his voice. If the customer replaced AR with an IP Phone, then this IP Phone will get the number 901454 and the IP address, then the call works right, no one-way call issue.

The related voice configuration in AR2200:
voice
voip-address media interface GigabitEthernet 0/0/0.30 172.16.27.2
voip-address signalling interface GigabitEthernet 0/0/0.30 172.16.27.2
area-code xx 901
pbx default-country-code xx default-area-code 901
#
trunk-group sip sip trunk-circuit
  signalling-address ip 172.16.27.2 port 5060
  media-ip 172.16.27.2
  peer-address static 10.8.19.97 5060 //The address of SBC in IMS network
……
#
callprefix 2
  enterprise default centrex hw_centrex
  prefix 2
  call-type category basic-service attribute 3
  digit-length 1 20
  destination-location inter-office
  callroute trunkgroup1 sip
#
callprefix 0901
  prefix 0901
  call-type category basic-service attribute 1
  digit-length 4 20
#
pbxuser 455 pots   // the local number
  port 2/0/3
  telno 455
  call-right in international-toll out international-toll
  centrex hw_centrex 455
  service-right call disable

Alarm Information

None

Handling Process

(1) Checked the configuration of AR, since the outgoing call started working, so the outgoing call configuration is OK.
(2) If the customer replaced AR with an IP Phone, then the call works right, no one-way call issue. packet and found that the peer address was 10.8.19.97, which is same as that configured on AR.
(3) packet in the outgoing call, we can see that the AR had sent the voice from local, but we didn’t know why the other end couldn’t hear it.

(4) So we asked the customer packet from IP Phone side. From the result we can find that AR didn’t send voice traffic to IP Phone. Compare to step(3), it seems that it’s IMS network problem, it dropped the voice traffic sent from AR(172.16.27.2) to IP Phone(172.16.21.5) .

(5) We asked the customer to ping from AR(172.16.27.2) to IP Phone(172.16.21.5) to test if the route is reachable, and it turned out that the route is not reachable.
   Check the configuration again, we found there were two static routes.
interface GigabitEthernet0/0/0.20
description Mgmt
dot1q termination vid 20
ip address 172.16.26.2 255.255.255.0
#
interface GigabitEthernet0/0/0.30
description VPN
dot1q termination vid 30
ip address 172.16.27.2 255.255.255.0
#
  ip route-static 0.0.0.0 0.0.0.0 172.16.26.1
      ip route-static 10.8.19.0 255.255.255.0 172.16.27.1  //for SBC in IMS network
From the above configuration, we can see the next hop to SBC from AR is 172.16.27.1, but the next hop to IP Phone(172.16.21.5) is 172.16.26.1. We had asked the customer many times to provide the detail topology of the network, but had no result.

For test, we asked the customer to add one more static
ip route-static 172.16.21.0 255.255.255.0 172.16.27.1  //for IP Phone

Then the other end can hear local end. The problem was resolved.
In this situation, we don’t know exactly the detail network topology. But we can try some solution to test it.

Root Cause

1) The peer address is not correct.
2) The IMS network drops the voice traffic sent from AR
3) The route between AR and IP Phone is not reachable

Suggestions

To make the voice call, it is a basic rule to make sure the route between two IP Phones is reachable.