No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

No rip route due to verifying source IP in P2P network in AR1200

Publication Date:  2019-07-17  |   Views:  311  |   Downloads:  0  |   Author:  y00303681  |   Document ID:  EKB1000060340

Contents

Issue Description

After finishing RIP related configuration, a customer found that both AR1200-1 and AR1200-2 had no RIP route.
This is the topology:

Here is the result:
[AR1200-1]display rip 1 route
[AR1200-1]
So was that in AR1200-2.
The related configuration in AR1200-1:
interface Serial2/0/0
link-protocol ppp
ip address 172.16.14.1 255.255.255.0
interface LoopBack0
ip address 10.0.1.1 255.255.255.0
#
rip 1
undo summary
version 2
network 10.0.0.0
network 172.16.0.0

The related configuration in AR1200-2:
interface Serial2/0/0
link-protocol ppp
ip address 10.0.14.4 255.255.255.0
rip summary-address 10.1.0.0 255.255.254.0
interface LoopBack0
ip address 10.1.0.1 255.255.255.0
#
interface LoopBack1
ip address 10.1.1.1 255.255.255.0rip 1
#
rip 1
undo summary
version 2
network 10.0.0.0

Alarm Information

None

Handling Process

(1) Ping each other, and it turned out the route was reachable.


(2)  packets in the interface Serial2/0/0, we found that both AR1200-1 and AR1200-2 sent Response RIP message to each other.

(3) Check the statistic in the RIP interface Serial2/0/0. We found that the Response packets received count is 0, which is so strange, because from step(2) we knew the interface Serial2/0/0 had received response packets.

(4) Simulated the situation in Lab using the interface GigabitEthernet, for there were no Serial cable, with such RIP configuration, the RIP protocol worked all right. Two ARs can learn RIP route of each other.
(5) So there should be some specific configuration for P2P network. Checked the product documentation again, and found that in P2P network, if the two ends had different IP network segment, this command “undo verify-source” is neened.

Root Cause

If the IP addresses on two ends of a P2P link belong to different network segments, the devices on the two ends cannot set up neighbor relationship unless source check is disabled.
By default, the source IP addresses in RIP Update packets are checked. RIP checks whether the IP addresses of interfaces that send and receive the Update packets are on the same network segment. If not, the device does not process the packets. That is why Response packets received count is 0 in step(3) even the interface Serial received the response packet.
So in such situation in this issue, we need to disabled source check

Solution

Change the configuration as follows:
In AR1200-1:
rip 1
undo summary
version 2
network 10.0.0.0
network 172.16.0.0
undo verify-source   //add this command

In AR1200-2:
rip 1
undo summary
version 2
network 10.0.0.0
undo verify-source   //add this command

After that, AR1200-1 and AR1200-2 generate RIP route.

Suggestions

 When configure RIP in P2P network, you should pay attention when the IP addresses on two ends of a P2P link belong to different network segments, don’t remember to configure “undo verify-source” in RIP view.