No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

Port Conflict

Publication Date:  2015-06-30  |   Views:  623  |   Downloads:  0  |   Document ID:  EKB1000080949

Contents

Issue Description

This topic describes how to rectify port conflict when the Tomcat is restarted.

Handling Process

The following describes how to rectify port conflict on the Agent Server.
1. Log in to the Agent Server as the elpis user.
2. Use the vi editor to open the /home/Elpis/tomcat7/conf/server.xml file and change the port numbers that conflict.

<!-- Define a non-SSL HTTP/1.1 Connector on port 8080 -->
   < Connector port="8081" maxHttpHeaderSize="8192"
    maxThreads="2000" minSpareThreads="25" 
    maxSpareThreads="75"
    enableLookups="false" redirectPort="8181" 
    maxProcessors="2000" acceptCount="2000" 
    connectionTimeout="30000" disableUploadTimeout="true" 
    URIEncoding="UTF-8"/>

Root Cause

If the problem described in Figure 5-1 occurs when the Tomcat is restarted, port numbers conflict.
Figure 5-1 Port conflict