Issue Description
After a call comes in to a teller, the teller answers the call, but the call is released immediately.
Handling Process
Step 1 Verify that the broadcast IP addresses on the MCC two-node cluster are the same.
1. Log in to the active and standby MCC servers as the Elpis user.
2. Run the cd /home/Elpis/tomcat6/webapps/MCC/WEB-INF/classes command to go to /home/Elpis/tomcat6/webapps/MCC/WEB-INF/classes.
3. Use the vi editor to open the ehcache.xml file and check the value of multicastGroupAddress in the ehcache.xml file.
This parameter indicates the broadcast IP address.
If the broadcast IP addresses on the MCC two-node cluster are different, change them to be the same.
Step 2 Verify that the broadcast IP address is available.
If the broadcast IP address is occupied by another server, allocate a unique broadcast IP address to the MCC server.
Step 3 Verify whether the eSpace Meeting server works correctly.
1. Log in to the active and standby eSpace Meeting servers as the econf user.
2. Run the ps -ef |grep econf command to check the running processes.
− If information similar to the following is displayed, the active and standby servers work correctly:
− Active eSpace Meeting server
econf 23678 22977 0 14:40 pts/0 00:00:00 grep econf
econf 24447 1 0 11:21 ? 00:01:45 mcsagt
econf 24448 1 1 11:21 ? 00:03:10 mcmgw
econf 24449 1 0 11:21 ? 00:01:26 mccaches
econf 24450 1 1 11:21 ? 00:03:07 mcms
econf 24588 1 0 11:22 ? 00:00:32 icdcomm
econf 24645 1 0 11:22 ? 00:00:39 idcenter
econf 24656 1 0 11:22 ? 00:00:39 idagent
econf 24701 1 1 11:22 ? 00:02:46 lom
econf 24742 1 0 11:22 ? 00:00:41 configDaemon -d
econf 24758 1 0 11:22 ? 00:00:41 namingDaemon -d
econf 24777 1 0 11:22 ? 00:00:41 toolDaemon -d
econf 24800 1 0 11:22 ? 00:00:41 idlproxy -d
econf 24887 1 0 11:22 ? 00:00:59 container 0 -d
econf 24997 24887 1 11:22 ? 00:03:30 container 1 -n -d
econf 24998 24887 0 11:22 ? 00:00:43 LicenseService 55 -n -d
econf 24999 24887 0 11:22 ? 00:00:42 CDRServer 303 -n -d
econf 25000 24887 8 11:22 ? 00:16:18 SDU 401 -n -d
econf 25001 24887 0 11:22 ? 00:00:54 eSpaceMeetingLicense 555 -n -d
− Standby eSpace Meeting server
econf 1681 1 0 08:42 ? 00:00:21 mcsagt
conf 1683 1 1 08:42 ? 00:01:42 mcmgw
econf 1684 1 0 08:42 ? 00:00:32 mccaches
econf 1685 1 1 08:42 ? 00:01:56 mcms
If the preceding information is not displayed, perform the following operations as the econf user:
− On the active eSpace Meeting server, run the following commands to restart the license management console and eSpace Meeting service.
start.sh -a
cd /home/econf/ms/bin
sh run.sh
− On the standby eSpace Meeting server, run the following commands to restart the eSpace Meeting service.
cd /home/econf/ms/bin
sh run.sh
3. Run the p command to check the status of the AS process.
The AS service is started on only one eSpace Meeting server. You only need to check the AS process on the server where the AS service is started.
If information similar to the following is displayed, the AS service works correctly:
UID PID PPID C STIME TTY TIME ALIASNAME
econf 24588 1 0 11:22 ? 00:00:39 icdcomm
econf 24645 1 0 11:22 ? 00:00:49 idcenter
econf 24656 1 0 11:22 ? 00:00:48 idagent
econf 24701 1 1 11:22 ? 00:03:21 lom
econf 24742 1 0 11:22 ? 00:00:51 configDaemon
econf 24758 1 0 11:22 ? 00:00:51 namingDaemon
econf 24777 1 0 11:22 ? 00:00:51 toolDaemon
econf 24800 1 0 11:22 ? 00:00:51 idlproxy
econf 24887 1 0 11:22 ? 00:01:13 container 0
econf 24997 24887 1 11:22 ? 00:04:19 container 1
econf 24998 24887 0 11:22 ? 00:00:53 LicenseService 55
econf 24999 24887 0 11:22 ? 00:00:52 CDRServer 303
econf 25000 24887 8 11:22 ? 00:20:09 SDU 401
econf 25001 24887 0 11:22 ? 00:01:06 eSpaceMeetingLicense 555
econf 25002 24887 0 11:22 ? 00:01:05 eSpaceMeetingCbu 599
econf 25003 24887 0 11:22 ? 00:00:55 eSpaceMeetingCmu 600
econf 25004 24887 0 11:22 ? 00:01:00 eSpaceMeetingFocus 601
econf 25005 24887 6 11:22 ? 00:15:51 eSpaceMeetingCru 602
econf 25006 24887 6 11:22 ? 00:16:03 eSpaceMeetingPtcpt 603
econf 25007 24887 0 11:22 ? 00:01:49 eSpaceMeetingMSRC 604
Step 4 Check whether the fault is rectified.
If yes, the procedure ends.
If no, contact Huawei technical support.
Root Cause
The broadcast IP addresses on the MCC two-node cluster are different or occupied by other servers.
The active or standby eSpace Meeting server works incorrectly.