No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

Network Access Through Multiple Outbound Interfaces of an AR Router Is Slow

Publication Date:  2015-08-19  |   Views:  208  |   Downloads:  0  |   Document ID:  EKB1000084636

Contents

Issue Description

As shown in Figure 1-1, an AR router functions as an enterprise's egress gateway and connects to the carrier's network through four outbound interfaces. The interfaces use fixed IP addresses. A user can normally open web pages and download files using any link. However, when multiple users use multiple links to connect to the network, network access and file downloading are slow.

Figure 1-1 An AR router has multiple outbound interfaces



The configuration file is as follows:


interface Vlanif1 
ip address 169.254.1.1 255.255.255.0 
dhcp select interface 
dhcp server dns-list 169.254.1.1 //Configure DHCP on the intranet interface connecting the AR router to PCs so that the router can dynamically assign IP addresses to the PCs.

interface Vlanif10 //Configuration on the interface of link 1. The IP address of the remote end is 117.29.164.253.
ip address 117.29.164.254 255.255.255.252 
nat outbound 2000    

interface GigabitEthernet0/0/0 //Configuration on the interface of link 2. The IP address of the remote end is 120.36.140.61.
tcp adjust-mss 1200 
ip address 120.36.140.62 255.255.255.252 
nat outbound 2000    

interface GigabitEthernet0/0/1 //Configuration on the interface of link 3. The IP address of the remote end is 120.36.140.33.
tcp adjust-mss 1200 
ip address 120.36.140.34 255.255.255.252 
nat outbound 2000    

interface GigabitEthernet0/0/2 //Configuration on the interface of link 4. The IP address of the remote end is 117.29.164.181.
tcp adjust-mss 1200 
ip address 117.29.164.182 255.255.255.252 
nat outbound 2000    
#
ip route-static 0.0.0.0 0.0.0.0 117.29.164.253
ip route-static 0.0.0.0 0.0.0.0 120.36.140.61
ip route-static 0.0.0.0 0.0.0.0 120.36.140.33
ip route-static 0.0.0.0 0.0.0.0 117.29.164.181

Handling Process

1. Check whether the quality of a link is poor. Run the shutdown command on the four outbound interfaces in sequence to test the link quality. The problem persists.

2. Check whether a load balancing problem occurs. Run the ip load-balance hash src-ip command to enable load balancing based on the source IP address. The problem persists.

3. Check whether a packet fragmentation problem occurs. Run the tcp adjust-mss command on VLANIF 10 to set the maximum segment size (MSS) of TCP packets to 1200 bytes. The test result shows that network access and file downloading are still slow.

4. Check whether an STP problem occurs. Run the undo stp enable command in the system view to disable STP. The test result shows that the network access rate is higher but does not meet the customer's bandwidth requirement.

5. The interface of link 1 is on an 8FE1GE card. Check whether packet forwarding on the interface is normal. Run the set workmode lan-card l3centralize command to disable the routing and forwarding function on high-end LAN cards (8FE1GE and 24GE cards). The test result shows that network access and file downloading are normal. The problem is fixed.

Suggestions

You are advised to troubleshoot the problem from the following aspects:

1. Link quality

2. Hash algorithm of links

3. TCP MSS value on an interface

4. STP

5. Routing and forwarding function of high-end LAN cards (8FE1GE and 24GE cards): Disable the routing and forwarding function on high-end LAN cards so that the router diverts packets received on the cards to the sub-core CPU. The sub-core CPU forwards the packets, improving packet forwarding efficiency.