No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

Safely delete the "Non-status" disk failed on FusionCompute portal with V100R003 version

Publication Date:  2016-04-21  |   Views:  398  |   Downloads:  0  |   Author:  c00507397  |   Document ID:  EKB1000114992

Contents

Issue Description

The status of the disk is unknown(no status) on the portal as below:

When performing the "safely delete" operation, we will see the error message as below:

The volume status is not USE

Alarm Information

The volume status is not USE

Handling Process

We can login the VRM database to check the status of that disk, and find the real status is as below:

Root Cause

We have confirmed the history operation for this abnormal disk, and find the root cause as below:

When detaching the disk from the Virtual Machine, they selected the "formatting" option, and the auto-formatting failed in the system, then the "FORMATFAILED" status will be recored in the VRM database.

And on the FusionCompute portal component, it will not recognize the "FORMATFAILED" status, when trying to delete the disk, system will report the error "The volume status is not USE".

Solution

This is an operation with high risk, please implement it with HUAWEI support engineer.

1. Check the volume_uuid inforamtion on the portal as below:

2. Login the VRM server with CLI, then connect to the VRM database with command "psql –U galax vrm"

3. Run the command below to update the status of the disk in the database:

update tbl_vs_volume set vol_status='USE' where volume_uuid='xxxxxxxxxxxxxxxxxxx';

4. After the change in the database, you will see the normal status on the FusionCompute portal as below, then you can perform the "safely delete".


 

Suggestions

None