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Knowledge Base

Using TWAIN Redirection to Solve Photo Taking Problems of High-Speed Document Scanners

Publication Date:  2016-10-26  |   Views:  548  |   Downloads:  0  |   Author:  h00228578  |   Document ID:  EKB1000339984

Contents

Issue Description

Service software fails to take photos using a high-speed document scanner.

Alarm Information

NA

Handling Process

NA

Root Cause

1.TWAIN redirection is not enabled. 

2.The customer's service software does not support the TWAIN protocol therefore cannot connect to TWAIN through redirection. 

3.The customer's service software does not support the directshow framework therefore cannot connect to cameras through redirection.

Solution

1.Enable the TWAIN redirection policy on the FusionAccess portal. 

2.Open the C:\Program Files\Huawei\Huawei vDesk\software\HDPDeviceHelper\NormalAnalyse and select Twack_32


3.(1) Open the software, click File > Select source, select the M500 high-speed document scanner. (2) Click the "Acquire" button under the file. The video window is displayed. Click Export and images can be viewed.

4.These operations cannot be performed on the customer's service software because the software does not support TWAIN redirection. TWAIN functions must be developed for the customer's service software.

Suggestions

NA