No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

Problem with QinQ service in VLL connection

Publication Date:  2017-05-10  |   Views:  410  |   Downloads:  0  |   Author:  maxim_begovatkin  |   Document ID:  EKB1000634288

Contents

Issue Description

Device-type: AR1220F
SW Version: AR1220F-V200R007C00SPCb00.cc

network configuration:



Devices configuration:

 HUAWEI AR1220F

router id 172.16.100.50

mpls lsr-id 172.16.100.50
mpls

mpls l2vpn

mpls ldp

vlan batch 3003

vlan 3003

interface GigabitEthernet0/0/0
 description ### MPLS P2P S6348EI XGi-0/0/42 ###
 ip address 172.16.105.206 255.255.255.252
 ospf cost 50
 ospf network-type p2p
 ospf timer hello 1
 ospf ldp-sync
 mpls
 combo-port fiber
 mpls ldp

interface GigabitEthernet0/0/1
 description ### Trk S2326F Gi0/0/1 ###

interface GigabitEthernet0/0/1.3003
 description ### Test_transit_QinQ_vlan_3003 ###
 dot1q termination vid 3003
mpls l2vc 172.16.0.101 3003

ospf 35000 router-id 172.16.100.50
 import-route direct
 import-route static
 silent-interface all
 undo silent-interface GigabitEthernet0/0/0
 enable log config
 enable log state
 enable log error
 enable log snmp-trap
 area 0.0.0.0
  network 172.16.105.204 0.0.0.3 description P2P_MPLS_S6348EI_Gi-0/0/0


 HUAWEI S6348EI

router id 172.16.0.101

mpls lsr-id 172.16.0.101
mpls

mpls l2vpn

mpls ldp

vlan batch 3003

vlan 3003

interface XGigabitEthernet0/0/42
 undo portswitch
 description ### MPLS P2P AR1220F XGi0/1/42 ###
 ip address 172.16.105.205 255.255.255.252
 ospf cost 50
 ospf network-type p2p
 ospf timer hello 1
 ospf ldp-sync
 mpls
 mpls ldp

interface XGigabitEthernet0/0/44
 description ### Trk S2326F-1 ###
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 3003

interface Vlanif3003
 description ### Test_transit_QinQ_vlan_3003 ###
 mpls l2vc 172.16.100.50 3003

ospf 35000 router-id 172.16.0.101
 import-route direct
 import-route static
 silent-interface all
 undo silent-interface XGigabitEthernet0/0/42
 enable log config
 enable log state
 enable log error
 enable log snmp-trap
 area 0.0.0.0
  network 172.16.105.204 0.0.0.3 description P2P_MPLS_AR1220F_XGi-0/0/42


HUAWEI S2326F-1

vlan batch 3003

interface GigabitEthernet0/0/1
 description ### Trk S6348EI XGi0/0/44 ###
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 3003

interface Ethernet0/0/5
 description ### Dot1q-tunnel to Customer ###
 port link-type dot1q-tunnel
 port default vlan 3003

HUAWEI S2326F-2

vlan batch 3003

interface GigabitEthernet0/0/1
 description ### Trk AR1220F Gi0/0/1 ###
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 3003

interface Ethernet0/0/5
 description ### Dot1q-tunnel to Customer ###
 port link-type dot1q-tunnel
 port default vlan 3003


Handling Process

 The problem in passing tagged customers traffic.
Untagged traffic passing normally.

The problem is only in AR1220F, in case of its replacement on other device (for example S6348EI) the problem disappears  in the current configuration.