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Knowledge Base

eSight SMS Gateway Test Failure

Publication Date:  2017-09-25  |   Views:  591  |   Downloads:  0  |   Author:  l00413522  |   Document ID:  EKB1000898849

Contents

Issue Description

Customer was unable to test the SMS gateway successfully and got error “http status code=400”.

Alarm Information

http status code=400

Handling Process

1. Under \eSight\AppBase\etc\oms.core\emailconfig.properties, check useExtensionImpl=HTTP_SMS. No problem.


2. Checkted if the parameters 3rd party SMS platform are correspondent to the those configured on eSight, like the Message content keyword and Recipient number keyword.


3. After confirming the two keywords matched, it doesn't work still. So try to change the Encode type from None to GBK. It can work. But it is just a workaround. Because the GBK is a Chinese encode type.

Root Cause

eSight with version V2R6SPC200 cannot select the encode type as UTF-8; so 3rd party SMS platform cannot handle the request packets. 

Solution

We already helped patch the V300R006C00SPC212; then we can choose the right encode type - UTF-8; problem was solved.