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Knowledge Base

USB-based development upgrade problem on AR161

Publication Date:  2018-08-10  |   Views:  931  |   Downloads:  0  |   Author:  p84079623  |   Document ID:  EKB1001787981

Contents

Issue Description

the customer receive error on usb based development making the upgrade.

1) The customer followed the guide building the INI file:
BEGIN AR
[USB CONFIG]
SN=20180228.090913
EMS_ONLINE_STATE=NO
[UPGRADE INFO]
OPTION=AUTO
AUTOFLAG=1
PASSWORD=Admin@huawei
DEVICENUM=1
[DEVICE1 DESCRIPTION]
OPTION=OK
ESN=DEFAULT
MAC=DEFAULT
VERSION=V200R007C00SPC000
DIRECTORY=DEFAULT
FILENUM=3
TYPE1=SYSTEM-CONFIG
FILENAME1=push161.cfg
FILE_HMAC1=fdfdbc526505dxxxxxxxxxxxxxxxxxxxxxxxxxxx7392ae209d60bcae4658c
TYPE2=SYSTEM-PAT
FILENAME1=AR160-V200R007SPH012.pat
FILE_HMAC2=862bc21f238xxxxxxxxxxxxxxxxxxxx7d2ed567054a5094d5
TYPE1=SYSTEM-SOFTWARE
FILENAME1=AR160-V200R007C00SPCb00.cc
FILE_HMAC3=209e2494xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxd93bf015fa20583115cfacbee2
END AR

2) The customer received this error during the upgrade execution:
.........
Info: FileType: SYSTEM-CONFIG, FileName: push161.cfg
Info: FileType: SYSTEM-PAT, FileName: AR160-V200R007SPH012.pat
Info: FileType: SYSTEM-SOFTWARE, FileName: AR160-V200R007C00SPCb00.ccError: TYPE is not matched.
Info :The SN is the same, however the startup file for the current startup is different from that in file INI, therefore the upgrade fails.

3) After correct some errors in the INI file, running again the upgrade with the correct parameters, the customer received again the error.

Handling Process

Check if running the upgrade the error is the one described.



Root Cause

First time the type and file names mismatched, second time the SN reference number of the upgrade was unchanged and the device didn’t executed the upgrade anymore because considered it already made.



Solution

Has been more errors to resolve.
1) Firstly we found not correct the TYPE and FILENAME NUMBERS:

The correctly sequence had to be this:

And in the version type has been to put just like this:

VERSION=V200R007C00


2) Because running again the upgrade the error didn’t disappeared, we asked to the customer to change the SN number in the INI file using one not used before. After this the upgrade run successfully.




Suggestions

Remember: the SN=20180228.090913 field number is to change every time that you lunch the upgrade on the same device. Because if an upgrade is made (also with error), the device memorize this number as upgrade made and will not execute the upgrade anymore. Is not important which number, important is that the number is different.