No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade
Knowledge Base

Incompatible Linux kernel cause SSD driver working abnormally.

Publication Date:  2019-09-20  |   Views:  255  |   Downloads:  0  |   Author:  rWX511507  |   Document ID:  EKB1001976155

Contents

Issue Description

one user purchased multiple ES series (ES3520S V3) SSD, and he used the ubuntu 16.04, after he intalled the standard SSD driver released by Huawei official team, but he still saw some error prompt about driver.



Alarm Information

Handling Process

After checked the OS logs, the SSD driver version has already been the latest , then we compared the OS kernel with supported Linux kernel, the kernel linux-4.15.0-36 was not in the compatible list which we supported.




Root Cause

Due to consider the stability, usually official team develped the corresponding driver based on the common Linux kernel. for ubuntu 16.04, it support kernel 4.4.0-21-generic and 4.4.0-31-generic and 4.4.0-62-generic and 4.4.0-131-generic.




Solution

we advised to use the matched Linux kernel.

for ubuntu 16.04, it supports kernel 4.4.0-21-generic and 4.4.0-31-generic and 4.4.0-62-generic and 4.4.0-131-generic


Suggestions

None