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Knowledge Base

PBX U1981 takes long time to detect when IP Phone goes offline

Publication Date:  2018-11-21  |   Views:  607  |   Downloads:  0  |   Author:  d84093304  |   Document ID:  EKB1002002870

Contents

Issue Description

When an IP Phone connected to a U1981 PBX goes offline, it takes a long time for the PBX to notice this, therefore affecting services like "Call forwarding when offline"

Handling Process

There are 3 “registration interval” settings involved in the SIP registration of IP phones to the PBX:
- A parameter named “SIP registration cycle”, that is set on the IP phone, and specifies the maximum time at which a registered phone is declared “offline” if it does not send a REGISTER message
- Two parameters on the PBX: “MinRegExpires” (this indicates the minimum registration interval at which an IP phone sends the registration request to the PBX) and “MaxRegExpires” (which indicates the maximum registration interval)

The relationship between this parameters is the following:
- If “SIP registration cycle” is smaller than “MinRegExpires”, than the value of “MinRegExpires” will be taken into consideration by the phone when sending registration requests to PBX
- If “SIP registration cycle” is larger than “MinRegExpires” but smaller than “MaxRegExpires”, then “SIP registration cycle” value will be taken into consideration
- If “SIP registration cycle” is larger than “MaxRegExpires”, then “MaxRegExpires” value will be taken into consideration

If you want just one IP phone to have smaller registration interval, then you can modify the setting on the IP phone.

If you want all the IP phones to have a smaller registration interval, then you will need to modify the PBX’s parameter “MaxRegExpires”

Root Cause

Parameter "MaxRegExpires" was set to the default value of 60 minutes, which is too large

Solution

Setting the parameter "MaxRegExpires" to a lower value (around 2-5 minutes) helped solve this issue.