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MU service is still offline

Publication Date:  2019-01-30 Views:  235 Downloads:  0
Issue Description

Issues with MU service still being offline even after a restart of the VCN.

Version of VCN510 is V100R002C30SPC200

Handling Process

     1. Restarting only the MU service from the web interface of the VCN but without any changes.
      2. Restarting the MU service via SSH as the below procedure was not working either:

-          enter with admin/Change_Me ( default credentials ) and then su – root to change to root user and insert default credentials Change_Me,

-          change the path to : cd /home/ivstool/bin

-          then insert command ./service.sh restart mu

-          to check if the mu service is running, insert  ps -ef | grep mu  or refresh the web interface of the VCN but also this procedure didn't help with the issue

 3. collected the MU service logs from Fault collection:


4. From the logs collected we have seen that the issue resides with blocks (MU/log/run):

2019-01-28 13:27:21.648+01:00|Warning|TID:0x72AFF460|query_Record_Mode success|uiRecordMode = 0, lensId = 09394010000000000101

2019-01-28 13:27:21.648+01:00|Warning|TID:0x72AFF460|try to get lastest block,| not exists this IPC:09394010000000000101a.

2019-01-28 13:27:21.648+01:00|   Info|TID:0x72AFF460|Get lastest block info of| ipc[09394010000000000101a], last stop time[0].

2019-01-28 13:27:21.648+01:00|Warning|TID:0x722FF460|query_Record_Mode success|uiRecordMode = 0, lensId = 06018510000000000101

2019-01-28 13:27:21.648+01:00|Warning|TID:0x722FF460|try to get lastest block,| not exists this IPC:06018510000000000101a.

2019-01-28 13:27:21.648+01:00|   Info|TID:0x722FF460|Get lastest block info of| ipc[06018510000000000101a], last stop time[0].


5. Check the disktype from VCN with the command /share/init.d/disktype




Root Cause

This issue will be solved in a future firmware version or patch and this is as a workaround when the MU is still offline and restarting the service or the VCN is not working.

Solution

If this is the case proceed with data rescue procedure to fix the issue:

step 1: Log in to the server as root user

step 2: insert /home/ivstool/bin/service.sh stop mu

step 3: insert cd /home/ivs_mu/bin

./data_rescue &

- make sure that the task is finished and then go to the next step as it needs at least 1h to finish

- to check if the task is finished insert command: ps -ef | grep  data_rescue

- if the data_rescue is not present in the output this means that the task is finished

step 4: /home/ivstool/bin/service.sh start mu

      

END