No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Third-Party Software Client Fails to Register to the IMS

Publication Date:  2019-04-04 Views:  163 Downloads:  0

Issue Description

CSC3300 version: V100R010C30SPC107

Fault symptom: A third-party software client registers to the IMS through the SBC. The software client sends a REGISTER message to the IMS, and the I-CSCF returns a 403 message. The registration fails.

Handling Process

1. The user definition data on the IMS side is confirmed normal.

2. Analysis on traced messages of the SBC and CSCF: After receiving the REGISTER message, the I-CSCF sends a UAR message to the HSS to obtain user authentication data. The HSS returns a UAA error message diameter-error-user-unknown. Upon the failure to obtain user authentication data, the I-CSCF returns a 403 message, and the registration fails. The following figure shows the details.

3. Check the format of user definition data on the HSS, which is IMPU=sip:+XXXXXXXXX@Domain name. However, the format of data carried in the From and To header fields of the REGISTER message sent by the third-party software client is IMPU=sip:+XXXXXXXXX@IP address (as shown in the following figure), which is inconsistent with the format on the HSS. After the IMPU number format is changed for the third-party software client so that the format is consistent with that of the user definition data on the HSS, the registration succeeds.

Root Cause

The IMPU number format carried in the From and To header fields of the REGISTER message is inconsistent with that of the user definition data on the HSS.

Solution

Change the IMPU number format for the third-party software client so that the format is consistent with that of the user definition data on the HSS.

END