No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

The S5700-10P-LI-AC and S5720 Are Directly Connected but Cannot Ping Each Other

Publication Date:  2019-04-08 Views:  38 Downloads:  0
Issue Description

The S5700-10P-LI-AC and S5720 are directly connected but cannot ping each other. Both the switches run V200R008C00SPC500.

The networking is as follows:

S5720 (four interfaces) ---- (four interfaces) S5700

The S5720 configuration is as follows:

vlan batch 10 to 18 61 100 120

interface Vlanif10

ip address 192.110.0.1 255.255.255.0

interface GigabitEthernet0/0/4

port default vlan 10 

The S5700 configuration (default VLAN 1 is used) is as follows:

interface Vlanif1

ip address 192.110.0.2 255.255.255.0

interface GigabitEthernet0/0/4

Handling Process

The S5720 does not learn the ARP entry corresponding to VLAN 10 of the peer end.

The two switches learn each other's MAC address. However, the VLAN in the MAC address entry learned by the S5720 is VLAN 1.

S5720:

c85b-76c3-4166 1/-                               GE0/0/4             dynamic   

c85b-76c3-4ae8 1/-                               GE0/0/4             dynamic

S5700:

0012-1344-a5eb 1/-                               GE0/0/4             dynamic   

002a-2b00-4994 1/-                               GE0/0/4             dynamic  

Theoretically, when interfaces on the S5720 are configured as access interfaces and the default VLAN is VLAN 10, the interfaces remove VLAN tags before sending packets out. Therefore, when VLAN 1 is configured as the default VLAN for interfaces on the S5700, the VLAN ID in the MAC address entry learned by the S5720 should be 10, instead of 1.

On the S5720, run the display vlan x command to check the VLAN information. It is found that GE0/0/4 joins VLAN 1 in untagged mode.

https://support.huawei.com/enterprisecase/product/images/e4c883830b4148d682a38f154501e847

 

VLAN 10 is configured as the default VLAN for GE0/0/4, but this interface joins VLAN 1. The problem may occur in either of the following situations:

interface GigabitEthernet0/0/4

port default vlan 10 

The default VLAN configuration does not take effect. This situation seldom occurs.

The Link-type Negotiation Protocol (LNP) is used to dynamically negotiate the link type of an Ethernet interface as access or trunk.

When the link type of an Ethernet interface is negotiated as access, the interface joins VLAN 1 by default.

When the link type of an Ethernet interface is negotiated as trunk, the interface joins VLANs 1 to 4094 by default.

LNP negotiation is not required on the live network, but this function has been enabled. Therefore, disable LNP negotiation on both switches.

Root Cause

LNP negotiation is enabled on switches. The link type of the interface on the S5720 is negotiated as access and joins VLAN 1, causing communication failure.

Solution


Run the lnp disable command in the system view.

<HUAWEI> system-view
[HUAWEI] lnp disable


Suggestions

LNP negotiation rules:

Local Link Type

Remote Link Type or LNP Negotiation Mode

Negotiated Local Link Type

Negotiated Remote Link Type

negotiation-desirable or negotiation-auto

Access (LNP negotiation enabled)

Access

Access

Hybrid (LNP negotiation enabled)

Trunk

Hybrid

Dot1q tunnel (LNP negotiation enabled)

Access

Dot1q-tunnel

Trunk (LNP negotiation enabled)

Trunk

Trunk

LNP negotiation not supported or disabled

Access

Uncertain

Negotiation-desirable

Negotiation-desirable

Trunk

Trunk

Negotiation-desirable

Negotiation-auto

Trunk

Trunk

Negotiation-auto

Negotiation-auto

Access

Access

                                                                                                                                        

LNP negotiation depends on communication between both ends. When the communication is delayed, the negotiated link type may be incorrect. The link type is considered in a stable negotiation state only after three rounds of communication are complete; otherwise, the link type of the interface remains in negotiation state. Before the link type enters the stable negotiation state, the interface is blocked and does not forward packets to prevent forwarding errors.

The VLAN Central Management Protocol (VCMP) domain name affects LNP negotiation. The link type can be negotiated as trunk only when domain names at both ends are the same or both empty; otherwise, the link type is negotiated as access.

END