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FusionCompute Cannot Find the System Storage of the CNA003 Host

Publication Date:  2019-04-12 Views:  26 Downloads:  0
Issue Description

Version:

FusionCompute V100R006C00U

FusionManager V100R006C00

Issue Description

During the installation of the IoM connectivity management platform, the data store needs to be added after the FusionCompute and FusionManager are installed. However, the system storage (RAID1) of the CNA003 host cannot be found. Only the data store (RAID5) is available. See the following figure.

Alarm Information
NONE
Handling Process

1. Log in to the CNA003 host using SSH.

Log in to the host as user gandalf (Huawei@CLOUD8), and then run the su - root command to switch to user root (Huawei@CLOUD8!).

Run the cat /pro/partitions command to query the current disk information.


The preceding information shows that sda is the system disk (RAID1) and sdb is the data disk (RAID5).

2. Run the pvdisplay, vgdisplay, and lvdispaly commands respectively to check the information about the physical volume, volume group, and logical volume.

The preceding figures show that the information (physical volume, volume group, and logical volume) about the system disk (RAID1) has been created for the host.

PV name: /dev/sda10, VG name: 5, LV name: /dev/5/5

This is suspected the cause of the problem.

3. Delete the LV, VG, and PV corresponding to RAID1 in sequence by running the following commands:

Lvremove /dev/5/5

    vgremove 5

pvremove /dev/sda10

After the deletion, run the pvdisplay, vgdisplay, and lvdispaly commands again to check whether the RAID1 information is deleted successfully.

4. Re-scan data stores on the FusionCompute. The system disk (RAID1) is successfully found.

Root Cause

This is not a new installation of CAN003. During the configuration in earlier installation, the data store had been added once. However, the data was not completely erased during RAID formatting and data erasing in the re-installation. The information (PV, VG, and LV) about the originally added system disk (RAID1) already exists. As a result, the FusionCompute considers that the system disk has been added and cannot be found through a new scan.

Solution

Use commands to delete the RAID1 information (PV, VG, and LV), and scan again on the FusionCompute.

Suggestions

For a host that is not newly installed, use commands to check related information, such as disks and partitions, in advance to prevent errors in subsequent configuration.

END