No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Certain Software Functional in a Template VM Cannot Be Used in VMs Provisioned Using This Template VM

Publication Date:  2019-04-16 Views:  32 Downloads:  0
Issue Description

In V100R006C20, certain application software is functional in a template VM but cannot be used in VMs provisioned using this template VM. Template inheritance has been configured as instructed in the product documentation.

Handling Process

1. On the template VM, copy the folder in the C:\user\Administrator\AppData directory to the C:\user\default\AppData to overwrite the original folder. Then, convert this VM to a template and provision VMs. The problem persists.

2. On a desktop cloud VM created using the template, rename the HWInject.sys file in the C:\Program Files\Huawei\HDPServer\Drivers and C:\Windows\System32\drivers directories (for example, rename the file as HWInject1.sys). It is found that the software can be used if the VM is logged in using VNC. However, when a user logs in to the VM through the WI, software on the VM still cannot be used. In addition, running the software interrupts the VM-desktop connection for several seconds.

Root Cause

Generally, this problem occurs because template inheritance is not configured or is incorrectly configured. Another possible reason is that the software is incompatible with the AccessAgent. For game software, Microsoft DirectX must be installed. However, common Windows 7 desktop cloud VMs do not support DirectX. If necessary, use the Windows 10 OS (installed with DirectX by default) or install a physical GPU to provide a GPU desktop VM.

Solution

1. On the template VM, copy the folder in the C:\user\Administrator\AppData directory to the C:\user\default\AppData to overwrite the original folder. Then, convert the VM to a template, provision VMs, and check whether the problem is resolved.

2. If the problem persists, rename the HWInject.sys file in the C:\Program Files\Huawei\HDPServer\Drivers and C:\Windows\System32\drivers directories (for example, rename the file as HWInject1.sys).

3. If the problem persists, install the AccessAgent of a later version.

Suggestions

Strictly follow instructions in the product documentation to configure template inheritance. Otherwise, many problems will occur. Generally, the problems can be resolved by re-preparing a template.

END