No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Users Cannot Watch Videos on the Integrated Service Platform

Publication Date:  2019-04-23 Views:  11 Downloads:  0
Issue Description

At a site, the upper-layer service platform (CVS) is integrated with the IVS SDK. The CVS platform invokes the IVS SDK. Operations such as creating users and adding cameras are performed on the CVS. The IVS underlying platform is invisible to users, and data is stored on the CVS platform. All user and camera information on the IVS platform is synchronized from the CVS through the SSO service. A customer reports that a user can log in to the CVS to view the organization structure, however, the videos cannot be played.<0}

Alarm Information
The CVS platform displays that the camera is offline.
Handling Process

1. Log in to the CVS and IVS as another user, and find that the video can be normally invoked.

2. Log in to the IVS and query the name of the user who cannot watch videos. It is found that the user name does not exist on the IVS and the number of users in the root user group is large.

3. Create a user group and drag users in the root user group to the new user group.

4. Log in to the CVS again as the user who cannot watch videos. The system displays a message prompting you to change the password upon the first login. Change the password and log in to the CVS again.

Root Cause

1. Users on the CVS are not synchronized to the IVS.

2. The IVS user group supports a maximum of 500 users, and the IVS synchronizes users from the CVS to the root user group by default. After 500 users are created, new users cannot be created.<0}

3. After the root user group is cleared, when the CVS user logs in for the first time, the signaling is sent to the IVS. If the IVS does not find the user, data synchronization is triggered and the user information is obtained from the CVS for creating this user in the root user group.

Solution

Ensure that the number of users in the root user group does not exceed 500.

It is recommended that R&D engineers develop a mechanism. When the number of users exceeds 500, another user group is automatically added and new users are transferred to the new group.<0}


Suggestions
Understanding the service process and mechanism helps quickly locate faults.

END