No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

UltraPath 21.0.1 Can Be Installed in Rocky 4.2.40 but Does Not Take Effect

Publication Date:  2019-04-23 Views:  58 Downloads:  0
Issue Description

Rocky 4.2.40 is included in the UltraPath 21.0.1 compatibility list. Scripts are executed to install UltraPath at the site, and no error is reported. However, after the system is restarted, the message "unable to detect ultrapath device node, exit" is displayed upon execution of the upadmin command.

Alarm Information

An alarm indicates that the UltraPath node cannot be detected.

Handling Process

1. The site has four servers. The same error is reported on these servers. It is inferred that the problem is caused by incompatibility. However, the operating system version is included in the UltraPath compatibility list.

2. During the UltraPath installation on each server, the local startup mode is selected. After the installation is completed, the operating system is restarted. Therefore, the installation mode is not the cause.

3. Scripts are executed to collect UltraPath logs from the host. It is found that the kernel version used by the operating system is not the version provided by the operating system.

Kernel version used at the site:

The version necessary to normal running of UltraPath:


4. It is recommended that the customer uninstall UltraPath and use the multipathing software provided by the operating system.


Root Cause

The kernel provided by the operating system is not used. If the kernel minor version in Linux is not supported by UltraPath, UltraPath can be installed but cannot be used.

Solution

Uninstall UltraPath and use the multipathing software provided by the operating system.

 

END