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Camera Status Fails to Be Synchronized from the Huawei Platform to the FiberHome Platform

Publication Date:  2019-04-25 Views:  20 Downloads:  0
Issue Description
Version: softVCN V100R002C50SPC203
Networking overview: Huawei softVCN adopts the cluster networking mode. The VMU two-node cluster manages the MPU in the cluster. All cameras at the site are connected to the MPU server of Huawei softVCN platform. The VMU connects to the FiberHome platform and shares the cameras to the FiberHome platform. Defect Details:
The FiberHome platform sends a message subscription request to Huawei platform. When the camera status changes, the Huawei softVCN platform notifies the FiberHome platform of the status change. However, there is a camera whose status is displayed as offline on the Huawei platform, but is displayed as online on the FiberHome platform.
 

Alarm Information

The camera status is not synchronized.

Handling Process

 1. Log in to the VMU as user root and run tcpdump-i any -s 1500 -w /home/XXX.cap host X.X.X.X -vvt (x.x.x.x is the IP address of the FiberHome platform).

2. Capture packets to check whether the Huawei platform sends a NOTIFY message to notify the FiberHome platform of the camera status changes. The ID of the offline camera is 3204910100131004435. The captured packets show that the Huawei platform (172.21.238.3) sends a NOTIFY message to the FiberHome platform (172.21.239.174), but the camera ID is 32049168991314437007. In this case, the NOTIFY message is incorrect, and the ID of the offline camera is not found after all NOTIFY messages are checked. Why does the Huawei platform not send the correct NOTIFY message? The ID of the offline camera is still not found after packets are captured for multiple times.

3. It is eventually found that, as shown in the following figure, the NOTIFY messages are sent every 60 seconds. Normally, the NOTIFY message is sent every time the status changes. The system does not wait for 60 seconds. It is confirmed that 60 seconds is the default waiting time when the system does not receive any responses from the peer platform.

4. The captured packets show that the FiberHome platform (172.21.239.1744) returns a 200 OK message to the NOTIFY message sent by the Huawei platform (172.21.238.3), as shown in the following figure.Why does the Huawei platform wait for 60 seconds to send the NOTIFY message again?
5. Compare Huawei's NOTIFY message with the 200 OK message returned by the FiberHome platform.
The FiberHome platform removes the tag information from the To field in the header when replying to the NOTIFY message. As a result, the Huawei platform cannot identify the 200 OK message, considers that the peer platform does not respond, and waits for 60 seconds to send the NOTIFY message again. For this situation, it is clearly defined in the GB28181 that the tag information must be carried and the format must be the same as that in NOTIFY message. For details, see the description in J.22.4, J.22.6, and J.22.10.

6.The reason why the offline camera ID is not found is that the NOTIFY message is sent in serial mode. Only one NOTIFY message can be sent at a time. The second sending can be triggered only after the response to the first NOTIFY message is received. Otherwise, the NOTIFY message can be sent for the second time only after 60 seconds. The 200 OK message returned by the FiberHome platform is not standard. As a result, all NOTIFY messages sent by Huawei platform need to wait for 60 seconds, and a large number of NOTIFY messages are queuing. Therefore, the NOTIFY message that carries the ID of the offline camera is waiting to be sent. 

7. The NOTIFY message is not sent to the FiberHome platform in time. As a result, the camera status on the FiberHome platform is inconsistent with that on the Huawei platform.





Root Cause
The FiberHome platform returns a 200 OK message that does not comply with the T28181 standards.

END