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SMC2.0 Does Not Respond to a Roll Call

Publication Date:  2019-04-25 Views:  63 Downloads:  0
Issue Description

The SMC2.0 (V100R002C04B018SP01) does not respond to a roll call. The roll call fails. After the user logs out and then logs in again, the roll call is successful.

Handling Process
1. The problem is caused by automatic recycling of the IIS application pool during a period of about 50 seconds from 8:51 to 8:52 on March 2.

2. The main purpose of automatic recycling of the application pool is to clean up memory errors and optimize access speed. This policy is a default setting of the Microsoft IIS component. You are not advised to disable it.
However, the default recycling period 1740 minutes (or 29 hours) is not appropriate. After several recycling periods, a new recycling task will start during working time.
When application pool recycling is in progress in the, all operation requests sent to the SMC website will time out or receive no response. This is consistent with the symptom provided by the customer that conference control returns to normal after the user logs out and re-logs in. According to the log time, the recycling is already completed and IIS is functioning properly after the user re-logs in.

3. To solve the problem, it is advised not to directly disable the recycling mechanism of the application pool. Instead, change the recycling time to early morning and the recycling period to 24 hours. As shown in the following figure, change the interval 1740 to 1440, and set Special Times to night hours when there is no service (the time is set to the 24-hour format).

Root Cause

The problem is caused by application pool recycling of the IIS service provided by Microsoft.


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