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Knowledge Base

There are no videos found in the play back recording VCN540

Publication Date:  2020-01-31  |   Views:  67  |   Downloads:  0  |   Author:  p84116261  |   Document ID:  EKB1100045222

Contents

Issue Description

After scheduling the recording for all day, and when we try to search for recording, system displays no videos found, as in the following:

16291442e3294a89b2c7fa625ceddd84

Handling Process

1) We checked status of the disk on the OMU, we found all normal

2) We found the times for all the cameras are different, so we enabled NTP, but still didn't fix the problem

3) We found the time between server and PC is different, we made the time the same but didn't fix the problem

4) We re-scheduled the the recordings for all the cameras, but still didn't fix

5) We found a pre-warning notice for the current versionV100R002C30, that disk may be offline and need to check by SSH

Root Cause

When the VCN5X0 is running, there is a probability that the disk is offline and recording fails

The VCN5X0 application checks whether a disk is online every minute using the following mechanism: Obtain the current disk SN and compare it with the initial disk SN recorded in the configuration file. If they are the same, the disk is online. Otherwise, the disk is offline. Due to a defect, the disk SN obtained by the VCN5X0 underlying driver occasionally contains extra space characters, which is different from that in the configuration file. As a result, the VCN5X0 application determines that the disk is offline or replaced.

After determining that the disk is offline or replaced, the VCN5X0 records the offline status of the disk in the /share/init.d/disktype configuration file and restarts. After the restart, the VCN5X0 regards that the disk is offline. As a result, the recording service is interrupted and cannot be automatically recovered.

Solution

Step 1      Obtain the new OMU library file, which will resolve the problem of obtaining incorrect disk SNs. The library file can be obtained from the package of the patch version V100R002C30SPC205. The path is as follows:

 VCN5x0 Product Package.zip

  |--vcn5x0.zip

   |--vcn5x0_install

    |-- ivs_omu_arm.tar.gz

     |-- lib

      |-- libcommon.so

   Step 2      Upload the obtained file to the /tmp directory on the VCN server through XFTP.

   Step 3      Log in to the VCN5X0 as the admin user through SSH and run the su - root  command to switch to the root user. The default passwords of the admin and root users are both Change_Me.

   Step 4      Replace the libcommon.so file in /home/ivs_omu/lib with that in /tmp.

mv /tmp/libcommon.so /home/ivs_omu/lib

   Step 5      Restore the disk type of the disktype file.

l   If the /share/init.d/tabledisk file exists, the disk is in non-RAID mode. Run the following command.

echo 0 > /share/init.d/disktype

l   If the /share/init.d/tabledisk file does not exist, the disk is in RAID mode. Run the following command.

echo 1 > /share/init.d/disktype

   Step 6      Restore the disk status.

 /home/ivs_sudo/ivs_omu/bin/auto_fresh_raid1table.sh 1

   Step 7      Run the reboot command to restart the VCN5X0.

----End

Suggestions

Upgrade to the latest version to avoid any issues done during installation