No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para conectar teléfonos IP a switches a través de LLDP-MED

Ejemplo para conectar teléfonos IP a switches a través de LLDP-MED

Descripción general

Si un dispositivo de voz admite LLDP y el campo network-policy TLV puede usarse para obtener el ID de VLAN de voz, configure el comando lldp tlv-enable med-tlv network-policy voice-vlan en el switch para asignar un ID de VLAN de voz al dispositivo de voz. El switch luego aumenta la prioridad del paquete a través de VLAN de voz.

Notas de configuración

  • Este ejemplo se aplica a todos los modelos de V200R002 y versiones posteriores.
  • El teléfono Avaya no puede obtener una dirección IP a través de DHCP dentro de 60s debido a la demora de la red u otras causas. Una vez que el temporizador expire, el teléfono Avaya envía paquetes etiquetados con VLAN 0 repetidamente. El switch procesa los paquetes etiquetados con VLAN 0 de la misma manera que los paquetes sin etiquetas, es decir, en la VLAN especificada por el PVID de una interfaz. Dichos paquetes no se procesan en la VLAN de voz. Como resultado, el teléfono Avaya no puede autenticarse y no se puede conectar al switch.
    Puede usar uno de los siguientes métodos para resolver el problema:
    • Método 1: En V200R003C00 y versiones posteriores, recomendamos que configure la VLAN de voz basada en OUI. Luego, el switch agrega el ID de VLAN de voz a los paquetes sin etiquetas, de modo que los paquetes se pueden reenviar en la VLAN de voz. Para obtener más detalles, consulte Ejemplo para conectar teléfonos IP a switches a través de VLAN de voz basada en OUI. Para los switches fijos (S5320EI, S6320EI) y switches modulares (excepto LE1D2S04SEC0, LE1D2X32SEC0, LE1D2H02QEC0, y tarjetas de la serie X), usted también puede usar el comando voice-vlan vlan-id enable include-tag0 para habilitar la VLAN de voz para paquetes etiquetados con VLAN 0 en V200R010 y versiones posteriores.
    • Método 2: Modifique el valor del temporizador de VLAN TEST del teléfono IP: Presione la tecla asterisco (*) e introduzca la contraseña para acceder al menú. Seleccione VLAN TEST y cambie el valor por defecto a 0 (sin tiempo de espera). Después de reiniciar el teléfono Avaya, la configuración del temporizador ya no está efectiva y debe reconfigurarse.
  • Solo V200R0007 y versiones posteriores permiten que los dispositivos de voz se conecten sin autenticación.
  • Para los teléfonos Mitel 5212, Option 128, Option 129, Option 130, y Option 131 se deben configurar en el grupo de direcciones de servidor DHCP; de lo contrario, estos teléfonos no pueden identificar los paquetes de DHCP Offer enviados por DHCP Server o conectarse en línea. La configuración en el switch es la siguiente:
    <Quidway> system-view
    [Quidway] ip pool ip-phone
    [Quidway-ip-pool-ip-phone] option 128 ip-address 10.20.20.1  //No hay ningún requisito para el valor configurado. Asegúrese de que los paquetes salientes lleven los campos.
    [Quidway-ip-pool-ip-phone] option 129 ip-address 11.20.20.1
    [Quidway-ip-pool-ip-phone] option 130 ascii MITEL IP PHONE
    [Quidway-ip-pool-ip-phone] option 131 ip-address 11.20.20.1
    

Requisitos de redes

En Figura 2-5, para ahorrar costos de inversión, el cliente requiere que los teléfonos IP se conecten a la red a través de VoIP. Los teléfonos IP son compatibles con LLDP y pueden obtener ID de VLAN de voz y prioridades de paquete desde el campo network-policy TLV. Para garantizar que los teléfonos IP se puedan conectar a la red, el plan de la red debe cumplir los siguientes requisitos:
  • Los paquetes de voz enviados por teléfonos IP pueden llevar etiquetas de VLAN. La prioridad de los paquetes de voz es alta, por lo que no es necesario que el switch aumente la prioridad de los paquetes de voz.
  • Los paquetes de voz se transmiten en VLAN 100.
  • Las direcciones IP de los teléfonos IP se asignan dinámicamente por el servidor DHCP, y se encuentran en un segmento de red diferente al del servidor DHCP.
  • Los teléfonos IP pueden conectarse sin autenticación porque el entorno de red está seguro.
Figura 2-5  Conexión de teléfonos IP a switches a través de LLDP-MED

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:
  1. Habilite LLDP globalmente y en interfaces, y configure el campo network-policy TLV que lleva el ID de VLAN de voz y la prioridad para una interfaz.
  2. Agregue una interfaz a una VLAN para que los paquetes de voz se reenvíen en la VLAN.
  3. Configure interfaces para confiar en la prioridad del paquete porque la prioridad de los paquetes de voz enviados por teléfonos IP es alta.
  4. Configure las funciones de relé DHCP y de servidor DHCP para que las direcciones IP se asignen a teléfonos IP.
  5. Configure un dominio AAA para la administración de teléfonos IP, y configure el switch para asignar una política de acceso a la red a los terminales de voz a través de un esquema de servicio. La política de acceso a la red define que los terminales de voz pueden conectarse en línea sin autenticación.

Procedimiento

  1. Habilite LLDP en SwitchA y configure el campo network-policy TLV en las interfaces.

    # Habilite LLDP globalmente.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] lldp enable  //Después de que LLDP esté habilitado globalmente, LLDP está habilitado en todas las interfaces por defecto.

    # Configure el campo network-policy TLV en las interfaces.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60  //Configure el switch para usar el campo TLV de la network-policy para asignar un ID de VLAN de voz y prioridad a teléfonos IP.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60  //Configure el switch para usar el campo TLV de la network-policy para asignar un ID de VLAN de voz y prioridad a teléfonos IP.
    [SwitchA-GigabitEthernet1/0/2] quit
    

  2. Agregue interfaces en SwitchA a una VLAN.

    # Cree VLAN 100.

    [SwitchA] vlan batch 100  //Configure la VLAN 100 en la que se transmite el tráfico de voz.
    

    # Agregue interfaces a VLAN 100.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid tagged vlan 100  //Agregue la interfaz a la voz de la VLAN 100 en modo etiquetado.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid tagged vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    

  3. Configure la interfaz para confiar en la prioridad del paquete.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] trust 8021p inner  //El comando Trust 8021p (interno) varía según el modelo del dispositivo.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] trust 8021p inner  //El comando Trust 8021p (interno) varía según el modelo del dispositivo.
    [SwitchA-GigabitEthernet1/0/2] quit
    

  4. Configure la función de relé DHCP y de servidor DHCP.
    1. Configure la función de relé DHCP en SwitchA.

      # Configurar la función de relé DHCP en una interfaz.

      [SwitchA] dhcp enable  //Habilite DHCP globalmente. Por defecto, DHCP está deshabilitado.
      [SwitchA] interface Vlanif 100  //Cree VLANIF 100.
      [SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0  //Asigne una dirección IP a VLANIF 100.
      [SwitchA-Vlanif100] dhcp select relay  //Habilite la función de relé de DHCP en VLANIF 100.
      [SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2  //Configure la dirección del servidor DHCP en el agente de relé de DHCP.
      [SwitchA-Vlanif100] quit
      

      # Cree VLANIF 200.

      [SwitchA] vlan batch 200
      [SwitchA] interface Vlanif 200
      [SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0  //Configure una dirección IP para VLANIF 200 para la comunicación con SwitchB.
      [SwitchA-Vlanif200] quit
      

      # Agregue la interfaz de enlace ascendente a VLAN 200.

      [SwitchA] interface gigabitethernet 1/0/3
      [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200
      [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200
      [SwitchA-GigabitEthernet1/0/3] quit
      

      # Configure un route estático por defecto.

      [SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2  //La dirección del siguiente salto de la ruta corresponde a la dirección IP de VLANIF 200 en SwitchB.
      

    2. Configure SwitchB como servidor DHCP para asignar direcciones IP a teléfonos IP.

      # Configure un grupo de direcciones.

      <Quidway> system-view
      [Quidway] sysname SwitchB
      [SwitchB] ip pool ip-phone  //Cree un grupo de direcciones.
      [SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1  //Configure la dirección del gateway en el servidor DHCP.
      [SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0  //Configure las direcciones IP asignables en el grupo de direcciones IP.
      [SwitchB-ip-pool-ip-phone] quit
      

      # Configure la función de servidor DHCP.

      [SwitchB] dhcp enable  //Habilite DHCP globalmente. Por defecto, DHCP está deshabilitado.
      [SwitchB] vlan batch 200
      [SwitchB] interface Vlanif 200  //Cree VLANIF 200.
      [SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0  //Asigne una dirección IP a VLANIF 200.
      [SwitchB-Vlanif200] dhcp select global  //Configure SwitchB para asignar direcciones IP desde el grupo de direcciones IP global al teléfono IP.
      [SwitchB-Vlanif200] quit
      

      # Agregue la interfaz de enlace descendente a VLAN 200.

      [SwitchB] interface gigabitethernet 1/0/3
      [SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200
      [SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200
      [SwitchB-GigabitEthernet1/0/3] quit

      # Configurar un route de retorno.

      [SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

  5. Configure un dominio AAA y configure el switch para asignar una política de acceso a la red a los terminales de voz a través de un esquema de servicio. La política de acceso a la red define que los terminales de voz pueden conectarse en línea sin autenticación.
    1. Configure un dominio AAA.

      # Cree y configure una plantilla de servidor RADIUS.

      [SwitchA] radius-server template cisco  //Cree una plantilla de servidor RADIUS llamada cisco.
      [SwitchA-radius-cisco] radius-server authentication 192.168.6.182 1812  //Configure la dirección IP y el número de puertos del servidor de autenticación RADIUS.
      [SwitchA-radius-cisco] radius-server accounting 192.168.6.182 1813  //Configure la dirección IP y el número de puertos del servidor de contabilidad RADIUS.
      [SwitchA-radius-cisco] quit
      

      # Configure un esquema de servicio y un esquema de autenticación.

      [SwitchA] aaa
      [SwitchA-aaa] service-scheme cisco  //Cree un esquema de servicio llamado cisco.
      [SwitchA-aaa-service-cisco] quit
      [SwitchA-aaa] authentication-scheme radius  //Establezca el modo de autenticación a RADIUS.
      [SwitchA-aaa-authen-radius] authentication-mode radius  //Establezca el modo de autenticación a RADIUS.
      [SwitchA-aaa-authen-radius] quit

      # Cree un dominio AAA y vincule la plantilla del servidor RADIUS y el esquema de autenticación al dominio AAA.

      [SwitchA-aaa] domain default  //Configure un dominio llamado default.
      [SwitchA-aaa-domain-default] authentication-scheme radius  //Enlace el esquema de autenticación radius al dominio.
      [SwitchA-aaa-domain-default] radius-server cisco  //Enlace la plantilla del servidor RADIUS cisco al dominio.
      [SwitchA-aaa-domain-default] service-scheme cisco  //Enlace la plantilla de servicio cisco al dominio.
      [SwitchA-aaa-domain-default] quit
      [SwitchA-aaa] quit
      

    2. Configure el switch para asignar una política de acceso a la red a los terminales de voz a través de un esquema de servicio. La política de acceso a la red define que los terminales de voz pueden conectarse en línea sin autenticación.

      • V200R007C00 y V200R008C00

        # Establezca el modo NAC a unificado.

        [SwitchA] authentication unified-mode  //Por defecto, el switch usa el modo unificado. Cuando se cambian los modos tradicional y unificado, el administrador debe guardar la configuración y reiniciar el switch para que la configuración tenga efecto.

        # Configure el switch para asignar una política de acceso a la red a terminales de voz a través de un esquema de servicio. La política de acceso a la red define que los terminales de voz pueden conectarse en línea sin autenticación.

        [SwitchA] authentication device-type voice authorize service-scheme cisco
        
      • V200R009C00 y versiones posteriores

        # Establezca el modo NAC a unificado.

        [SwitchA] authentication unified-mode  //Por defecto, el switch usa el modo unificado. Cuando se cambian los modos tradicional y unificado, el administrador debe guardar la configuración y reiniciar el switch para que la configuración tenga efecto.

        # Configure un perfil de autenticación.

        [SwitchA] authentication-profile name cisco  //Cree un perfil de autenticación llamado cisco.
        [SwitchA-authen-profile-cisco] authentication device-type voice authorize service-scheme cisco  //Configure el switch para asignar una política de acceso a la red a los terminales de voz a través de un esquema de servicio. La política de acceso a la red define que los terminales de voz pueden conectarse en línea sin autenticación.
        [SwitchA-authen-profile-cisco] quit

        # Aplique el perfil de autenticación a las interfaces.

        [SwitchA] interface gigabitethernet 1/0/1
        [SwitchA-GigabitEthernet1/0/1] authentication-profile cisco  //Enlace el perfil de autenticación a la interfaz.
        [SwitchA-GigabitEthernet1/0/1] quit
        [SwitchA] interface gigabitethernet 1/0/2
        [SwitchA-GigabitEthernet1/0/2] authentication-profile cisco
        [SwitchA-GigabitEthernet1/0/2] quit
        

  6. Verifique la configuración

    • Puede ver que el teléfono IP puede obtener correctamente el ID de VLAN de voz y la dirección IP a través del menú del teléfono IP.
    • La salida del comando display mac-address vlan 100 en SwitchA muestra información de conexión sobre teléfonos IP.
      [SwitchA] display mac-address vlan 100
      -------------------------------------------------------------------------------                                                     
      MAC Address    VLAN/VSI                       Learned-From        Type                                                           
      -------------------------------------------------------------------------------                                                     
      001b-d4c7-1fa9 100/-                          GE1/0/1             dynamic                                                         
      0021-a08f-2fa8 100/-                          GE1/0/2             dynamic                                                         
                                                                                                                                          
      -------------------------------------------------------------------------------

Archivos de configuración

  • Archivo de configuración de SwitchA (V200R007C00 y V200R008C00)
    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    lldp enable
    #
    dhcp enable
    #
    authentication device-type voice authorize service-scheme cisco
    #
    radius-server template cisco
     radius-server authentication 192.168.6.182 1812 weight 80
     radius-server accounting 192.168.6.182 1813 weight 80
    #
    aaa
     authentication-scheme radius
      authentication-mode radius
     service-scheme cisco  
     domain default
      authentication-scheme radius
      radius-server cisco
    #
    interface Vlanif100
     ip address 10.20.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.10.20.2
    #
    interface Vlanif200
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1       
     port hybrid tagged vlan 100                                                                                                        
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
    #
    interface GigabitEthernet1/0/2       
     port hybrid tagged vlan 100
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
    #
    interface GigabitEthernet1/0/3       
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    #
    return
    
  • Archivo de configuración de SwitchA (V200R009C00 y versiones posteriores)
    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    authentication-profile name cisco
     authentication device-type voice authorize service-scheme cisco
    #
    lldp enable
    #
    dhcp enable
    #
    radius-server template cisco
     radius-server authentication 192.168.6.182 1812 weight 80
     radius-server accounting 192.168.6.182 1813 weight 80
    #
    aaa
     authentication-scheme radius
      authentication-mode radius
     service-scheme cisco
     domain default
      authentication-scheme radius
      service-scheme cisco 
      radius-server cisco
    #
    interface Vlanif100
     ip address 10.20.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.10.20.2
    #
    interface Vlanif200
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1       
     port hybrid tagged vlan 100
     authentication-profile cisco
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
    #
    interface GigabitEthernet1/0/2       
     port hybrid tagged vlan 100
     authentication-profile cisco
     trust 8021p inner                                                                                                                  
     lldp tlv-enable med-tlv network-policy voice-vlan vlan 100 cos 6 dscp 60
    #
    interface GigabitEthernet1/0/3       
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    #
    return
    
  • Archivo de configuración de SwitchB
    #
    sysname SwitchB
    #
    vlan batch 200
    #
    dhcp enable
    #
    ip pool ip-phone
     gateway-list 10.20.20.1 
     network 10.20.20.0 mask 255.255.255.0 
    #
    interface Vlanif200
     ip address 10.10.20.2 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15596

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente