No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para conectar un teléfonos IP a switches a través del servidor DHCP

Ejemplo para conectar un teléfonos IP a switches a través del servidor DHCP

Descripción general

Si un dispositivo de voz es compatible con DHCP, se puede habilitar DHCP en el switch y se puede asignar un ID de VLAN de voz a un dispositivo de voz a través de DHCP.

Notas de configuración

A continuación se describen los modelos y versiones de productos aplicables.
Tabla 2-4  Modelos de productos y versiones aplicables

Serie

Modelo del producto

Versión del software

S2300

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI, S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306, S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E, S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para obtener más información sobre los mapeos de software, consulte Version Mapping Search for Huawei Campus Switches.

Requisitos de redes

En Figura 2-7, el teléfono IP puede obtener un ID de VLAN de voz a través de DHCP, y la prioridad de los paquetes de voz enviados por el teléfono IP es alta (por ejemplo, la prioridad 802.1p es de 5). El campo de opción está configurado en el servidor DHCP para que el servidor DHCP proporcione el ID de VLAN al dispositivo de voz.

Figura 2-7  Conexión de un teléfono IP a un switch a través del servidor DHCP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:
  1. Cree las VLAN.
  2. Configure el tipo de enlace y la VLAN por defecto de la interfaz conectada al dispositivo de voz.
  3. Configure la interfaz para confiar en la prioridad 802.1p de los paquetes.
  4. Configure un grupo de direcciones IP.
  5. Configure el campo de opción en el grupo de direcciones.
  6. Habilite DHCP globalmente y configure el servidor DHCP en la interfaz VLANIF para asignar direcciones IP utilizando el grupo de direcciones IP global.

Procedimiento

  1. Configure las VLAN y una interfaz en el Switch.

    # Cree VLAN 2 y VLAN 6.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 2 6
    

    # Configure el tipo de enlace y la VLAN por defecto de la interfaz conectada al teléfono IP.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 2   //El tipo de enlace predeterminado de una interfaz es híbrido y no debe ser configurado manualmente.
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 2  //Agregue la interfaz a la VLAN 2 donde se reenvían los paquetes de datos.
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 6  //Agregue la interfaz a la VLAN 2 donde se reenvían los paquetes de datos.
    [Switch-GigabitEthernet1/0/1] quit
    

  2. Configure un grupo de direcciones IP en el switch.

    # Cree un grupo de direcciones IP.

    [Switch] ip pool ip_access

    # Configure el rango de direcciones en el grupo de direcciones IP.

    [Switch-ip-pool-ip_access] network 192.168.10.0 mask 24
    [Switch-ip-pool-ip_access] gateway-list 192.168.10.1  //Configure la dirección del gateway de salida del servidor DHCP. La dirección es la dirección IP de la interfaz VLANIF correspondiente al PVID.
    [Switch-ip-pool-ip_access] option184 voice-vlan 6  //Configure la VLAN de voz 6 correspondiente a Option 184 del grupo de direcciones DHCP.
    [Switch-ip-pool-ip_access] quit
    
    NOTA:
    El campo de opción está configurado en el servidor DHCP para que el servidor DHCP proporcione un ID de VLAN a un dispositivo de voz. Este ejemplo usa opción 184. Los teléfonos IP de diferentes proveedores pueden usar diferentes campos de option. Vea la documentación del teléfono IP. Para obtener detalles sobre cómo configurar una opción, consulte el comando option en the IP Service Commands - DHCP Configuration Commands.

  3. Configure la interfaz para confiar en la prioridad 802.1p de los paquetes.

    # El comando trust 8021p (inner) varía según el modelo del dispositivo.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] trust 8021p inner
    [Switch-GigabitEthernet1/0/1] quit
    

  4. Habilite DHCP globalmente

    [Switch] dhcp enable

  5. Configure un grupo de direcciones IP en el switch.

    # Cree la interfaz VLANIF correspondiente a la VLAN por defecto de la interfaz. Configure el servidor DHCP en la interfaz VLANIF para asignar direcciones IP utilizando el grupo de direcciones IP global.

    [Switch] interface Vlanif2
    [Switch-Vlanif2] ip address 192.168.10.1 255.255.255.0
    [Switch-Vlanif2] dhcp select global  //Configure el switch para asignar direcciones IP desde el grupo de direcciones global a clientes DHCP.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 2 6
#                                                                               
dhcp enable                                                                     
#
ip pool ip_access                                                               
 gateway-list 192.168.10.1
 network 192.168.10.0 mask 255.255.255.0                                        
 option184 voice-vlan 6
#                                                                               
interface Vlanif2                                                               
 ip address 192.168.10.1 255.255.255.0                                          
 dhcp select global                                                             
#                                                                               
interface GigabitEthernet1/0/1
 port hybrid pvid vlan 2                                                         
 port hybrid tagged vlan 6    
 port hybrid untagged vlan 2  
 trust 8021p inner
# 
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15677

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente