No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para conectar teléfonos IP a switches a través de la asignación de VLAN basada en direcciones MAC

Ejemplo para conectar teléfonos IP a switches a través de la asignación de VLAN basada en direcciones MAC

Descripción general

Si un dispositivo de voz no es compatible con LLDP o DHCP, un switch no puede asignarle un ID de VLAN de voz. Puede configurar la asignación de VLAN basada en direcciones MAC en el switch. Luego, el switch identifica los paquetes de voz según la dirección MAC del dispositivo de voz y aumenta la prioridad de los paquetes de voz.

Notas de configuración

  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.
  • El teléfono Avaya no puede obtener una dirección IP a través de DHCP dentro de 60s debido a la demora de la red u otras causas. Una vez que el temporizador expire, el teléfono Avaya envía paquetes etiquetados con VLAN 0 repetidamente. El switch procesa los paquetes etiquetados con VLAN 0 de la misma manera que los paquetes sin etiquetas, es decir, en la VLAN especificada por el PVID de una interfaz. Dichos paquetes no se procesan en la VLAN de voz. Como resultado, el teléfono Avaya no puede autenticarse y no se puede conectar al switch.
    Puede usar uno de los siguientes métodos para resolver el problema:
    • Método 1: En V200R003C00 y versiones posteriores, recomendamos que configure la VLAN de voz basada en OUI. Luego, el switch agrega el ID de VLAN de voz a los paquetes sin etiquetas, de modo que los paquetes se pueden reenviar en la VLAN de voz. Para obtener más detalles, consulte Ejemplo para conectar teléfonos IP a switches a través de VLAN de voz basada en OUI. Para los switches fijos (S5320EI, S6320EI) y switches modulares (excepto LE1D2S04SEC0, LE1D2X32SEC0, LE1D2H02QEC0, y tarjetas de la serie X), usted también puede usar el comando voice-vlan vlan-id enable include-tag0 para habilitar la VLAN de voz para paquetes etiquetados con VLAN 0 en V200R010 y versiones posteriores.
    • Método 2: Modifique el valor del temporizador de VLAN TEST del teléfono IP: Presione la tecla asterisco (*) e introduzca la contraseña para acceder al menú. Seleccione VLAN TEST y cambie el valor por defecto a 0 (sin tiempo de espera). Después de reiniciar el teléfono Avaya, la configuración del temporizador ya no está efectiva y debe reconfigurarse.
  • Para los teléfonos Mitel 5212, Option 128, Option 129, Option 130, y Option 131 se deben configurar en el grupo de direcciones de servidor DHCP; de lo contrario, estos teléfonos no pueden identificar los paquetes de DHCP Offer enviados por DHCP Server o conectarse en línea. La configuración en el switch es la siguiente:
    <Quidway> system-view
    [Quidway] ip pool ip-phone
    [Quidway-ip-pool-ip-phone] option 128 ip-address 10.20.20.1  //No hay ningún requisito para el valor configurado. Asegúrese de que los paquetes salientes lleven los campos.
    [Quidway-ip-pool-ip-phone] option 129 ip-address 11.20.20.1
    [Quidway-ip-pool-ip-phone] option 130 ascii MITEL IP PHONE
    [Quidway-ip-pool-ip-phone] option 131 ip-address 11.20.20.1
    

Requisitos de redes

En Figura 2-8, para ahorrar costos de inversión, el cliente requiere que los teléfonos IP se conecten a la red a través de VoIP. Los teléfonos IP no pueden obtener ID de VLAN de voz y solo pueden enviar paquetes de voz sin etiquetas. Para garantizar que los teléfonos IP se puedan conectar a la red, el plan de la red debe cumplir los siguientes requisitos:
  • La prioridad de los paquetes de voz debe aumentarse para garantizar la calidad de la comunicación.
  • Los paquetes de voz se transmiten en VLAN 100.
  • Las direcciones IP de los teléfonos IP se asignan dinámicamente por el servidor DHCP, y se encuentran en un segmento de red diferente al del servidor DHCP.
  • Los teléfonos IP pueden conectarse sin autenticación porque el entorno de red está seguro.
Figura 2-8  Conexión de teléfonos IP a switches a través de la asignación de VLAN basada en direcciones MAC

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:
  1. Agregue una interfaz a una VLAN en modo sin etiqueta para que los paquetes de voz se reenvíen en la VLAN.
  2. Configure la asignación de VLAN basada en direcciones MAC para que el switch agregue un ID de VLAN a los paquetes de voz y aumente la prioridad de los paquetes de voz.
  3. Configure las funciones de relé DHCP y de servidor DHCP para que las direcciones IP se asignen a teléfonos IP.

Procedimiento

  1. Agregue una interfaz en SwitchA a una VLAN.

    # Cree VLAN 100.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100  //Configure la VLAN 100 en la que se transmite el tráfico de voz.
    

    # Agregue una interfaz a la VLAN 100 en modo sin etiqueta.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100  //Los paquetes enviados por teléfonos IP no llevan etiquetas, por lo que la interfaz debe unirse a la VLAN 100 en modo sin etiqueta.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    

  2. Habilite la asignación de VLAN basada en direcciones MAC.

    [SwitchA] vlan 100
    [SwitchA-vlan100] mac-vlan mac-address 001b-d4c7-1fa9 ffff-ffff-0000 priority 6  //La dirección MAC corresponde a la dirección MAC del teléfono IP. La máscara puede ser utilizada. Este comando agrega la VLAN 100 a los paquetes sin etiquetas con la dirección MAC de origen que comienza desde 001b-d4c7 y cambia la prioridad de 802.1p a 6.
    [SwitchA-vlan100] mac-vlan mac-address 0021-a08f-0000 ffff-ffff-0000 priority 6
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] mac-vlan enable  //Habilite la asignación de VLAN basada en direcciones MAC en una interfaz. Cuando la interfaz recibe paquetes etiquetados, los paquetes se procesan según el enlace entre las direcciones MAC y las VLAN.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] mac-vlan enable
    [SwitchA-GigabitEthernet1/0/2] quit
    

  3. Configure la función de relé DHCP y de servidor DHCP.
    1. Configure la función de relé DHCP en SwitchA.

      # Configurar la función de relé DHCP en una interfaz.

      [SwitchA] dhcp enable  //Habilite DHCP globalmente. Por defecto, DHCP está deshabilitado.
      [SwitchA] interface Vlanif 100  //Cree VLANIF 100.
      [SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0  //Asigne una dirección IP a VLANIF 100.
      [SwitchA-Vlanif100] dhcp select relay  //Habilite la función de relé de DHCP en VLANIF 100.
      [SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2  //Configure la dirección del servidor DHCP en el agente de relé de DHCP.
      [SwitchA-Vlanif100] quit
      

      # Cree VLANIF 200.

      [SwitchA] vlan batch 200
      [SwitchA] interface Vlanif 200
      [SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0  //Configure una dirección IP para VLANIF 200 para la comunicación con SwitchB.
      [SwitchA-Vlanif200] quit
      

      # Agregue la interfaz de enlace ascendente a VLAN 200.

      [SwitchA] interface gigabitethernet 1/0/3
      [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200
      [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200
      [SwitchA-GigabitEthernet1/0/3] quit
      

      # Configure un route estático por defecto.

      [SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2  //La dirección del siguiente salto de la ruta corresponde a la dirección IP de VLANIF 200 en SwitchB.
      

    2. Configure SwitchB como servidor DHCP para asignar direcciones IP a teléfonos IP.

      # Configure un grupo de direcciones.

      <Quidway> system-view
      [Quidway] sysname SwitchB
      [SwitchB] ip pool ip-phone  //Cree un grupo de direcciones.
      [SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1  //Configure la dirección del gateway en el servidor DHCP.
      [SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0  //Configure las direcciones IP asignables en el grupo de direcciones IP.
      [SwitchB-ip-pool-ip-phone] quit
      

      # Configure la función de servidor DHCP.

      [SwitchB] dhcp enable  //Habilite DHCP globalmente. Por defecto, DHCP está deshabilitado.
      [SwitchB] vlan batch 200
      [SwitchB] interface Vlanif 200  //Cree VLANIF 200.
      [SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0  //Asigne una dirección IP a VLANIF 200.
      [SwitchB-Vlanif200] dhcp select global  //Configure SwitchB para asignar direcciones IP desde el grupo de direcciones IP global al teléfono IP.
      [SwitchB-Vlanif200] quit
      

      # Agregue la interfaz de enlace descendente a VLAN 200.

      [SwitchB] interface gigabitethernet 1/0/3
      [SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200
      [SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200
      [SwitchB-GigabitEthernet1/0/3] quit

      # Configurar un route de retorno.

      [SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

  4. Verifique la configuración

    • Puede ver que el teléfono IP puede obtener correctamente el ID de VLAN de voz y la dirección IP a través del menú del teléfono IP.
    • La salida del comando display mac-address vlan 100 en SwitchA muestra información de conexión sobre teléfonos IP.
      [SwitchA] display mac-address vlan 100
      -------------------------------------------------------------------------------                                                     
      MAC Address    VLAN/VSI                       Learned-From        Type                                                           
      -------------------------------------------------------------------------------                                                     
      001b-d4c7-1fa9 100/-                          GE1/0/1             dynamic                                                         
      0021-a08f-2fa8 100/-                          GE1/0/2             dynamic                                                         
                                                                                                                                          
      -------------------------------------------------------------------------------

Archivos de configuración

  • Archivo de configuración de SwitchA
    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    dhcp enable
    #
    vlan 100
     mac-vlan mac-address 001b-d4c7-1fa9 ffff-ffff-0000 priority 6
     mac-vlan mac-address 0021-a08f-0000 ffff-ffff-0000 priority 6
    #
    interface Vlanif100
     ip address 10.20.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.10.20.2
    #
    interface Vlanif200
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1       
     port hybrid untagged vlan 100
     mac-vlan enable
    #
    interface GigabitEthernet1/0/2       
     port hybrid untagged vlan 100
     mac-vlan enable
    #
    interface GigabitEthernet1/0/3       
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    #
    return
    
  • Archivo de configuración de SwitchB
    #
    sysname SwitchB
    #
    vlan batch 200
    #
    dhcp enable
    #
    ip pool ip-phone
     gateway-list 10.20.20.1 
     network 10.20.20.0 mask 255.255.255.0 
    #
    interface Vlanif200
     ip address 10.10.20.2 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15728

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente