No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para conectar teléfonos IP a switches a través del PVID del ID de VLAN de voz

Ejemplo para conectar teléfonos IP a switches a través del PVID del ID de VLAN de voz

Descripción general

Si un dispositivo de voz envía paquetes con la etiqueta 0 o paquetes sin etiquetas, el PVID de una interfaz se puede agregar a los paquetes de voz. Entonces, la prioridad de los paquetes de voz aumenta en función del ID de VLAN.

Notas de configuración

  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.
  • Para los teléfonos Mitel 5212, Option 128, Option 129, Option 130, y Option 131 se deben configurar en el grupo de direcciones de servidor DHCP; de lo contrario, estos teléfonos no pueden identificar los paquetes de DHCP Offer enviados por DHCP Server o conectarse en línea. La configuración en el switch es la siguiente:
    <Quidway> system-view
    [Quidway] ip pool ip-phone
    [Quidway-ip-pool-ip-phone] option 128 ip-address 10.20.20.1  //No hay ningún requisito para el valor configurado. Asegúrese de que los paquetes salientes lleven los campos.
    [Quidway-ip-pool-ip-phone] option 129 ip-address 11.20.20.1
    [Quidway-ip-pool-ip-phone] option 130 ascii MITEL IP PHONE
    [Quidway-ip-pool-ip-phone] option 131 ip-address 11.20.20.1
    

Requisitos de redes

En Figura 2-10, para ahorrar costos de inversión, el cliente requiere que los teléfonos IP y se conecten a la red a través de VoIP. Los teléfonos IP no pueden obtener ID de VLAN de voz y solo pueden enviar paquetes de voz sin etiquetas. Para garantizar que los teléfonos IP se puedan conectar a la red, el plan de la red debe cumplir los siguientes requisitos:
  • La prioridad de los paquetes de voz aumenta para garantizar la calidad de comunicación de los teléfonos IP.
  • Los paquetes de voz se transmiten en VLAN 100.
  • Las direcciones IP de los teléfonos IP se asignan dinámicamente por el servidor DHCP, y se encuentran en un segmento de red diferente al del servidor DHCP.
  • Los teléfonos IP necesitan conectarse a los switches a través de la autenticación de la dirección MAC.
Figura 2-10  Conexión de teléfonos IP a switches a través del PVID del ID de VLAN de voz

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:
  1. Agregue una interfaz a una VLAN en modo sin etiqueta para que los paquetes de voz se reenvíen en la VLAN.
  2. Habilite la función de VLAN de voz en una interfaz y configure el PVID de la interfaz con el ID de VLAN de voz.
  3. Configure las funciones de relé DHCP y de servidor DHCP para que las direcciones IP se asignen a teléfonos IP.
  4. Configure la autenticación para que los teléfonos IP se conecten a la red a través de la autenticación de la dirección MAC.

Procedimiento

  1. Agregue una interfaz en SwitchA a una VLAN.

    # Cree VLAN 100.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100  //Configure la VLAN 100 en la que se transmite el tráfico de voz.
    

    # Agregue una interfaz a la VLAN 100 en modo sin etiqueta.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100  //Los paquetes enviados por teléfonos IP no llevan etiquetas, por lo que la interfaz debe unirse a la VLAN 100 en modo sin etiqueta.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    

  2. Habilite la función de VLAN de voz en una interfaz de SwitchA y configure el PVID de la interfaz con el ID de VLAN de voz.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] voice-vlan 100 enable  //Habilite la función de VLAN de voz en la interfaz.
    [SwitchA-GigabitEthernet1/0/1] voice-vlan remark-mode mac-address  //En V200R003 y versiones posteriores, la interfaz debe configurarse para identificar paquetes de voz basados en direcciones MAC. Esta configuración no es necesaria en versiones anteriores de V200R003.
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100  //Configure el PVID.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2  //La configuración de GE1/0/2 es similar a la configuración de GE1/0/1.
    [SwitchA-GigabitEthernet1/0/2] voice-vlan 100 enable
    [SwitchA-GigabitEthernet1/0/2] voice-vlan remark-mode mac-address
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000
    [SwitchA] voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000

  3. Configure la función de relé DHCP y de servidor DHCP.
    1. Configure la función de relé DHCP en SwitchA.

      # Configurar la función de relé DHCP en una interfaz.

      [SwitchA] dhcp enable  //Habilite DHCP globalmente. Por defecto, DHCP está deshabilitado.
      [SwitchA] interface Vlanif 100  //Cree VLANIF 100.
      [SwitchA-Vlanif100] ip address 10.20.20.1 255.255.255.0  //Asigne una dirección IP a VLANIF 100.
      [SwitchA-Vlanif100] dhcp select relay  //Habilite la función de relé de DHCP en VLANIF 100.
      [SwitchA-Vlanif100] dhcp relay server-ip 10.10.20.2  //Configure la dirección del servidor DHCP en el agente de relé de DHCP.
      [SwitchA-Vlanif100] quit
      

      # Cree VLANIF 200.

      [SwitchA] vlan batch 200
      [SwitchA] interface Vlanif 200
      [SwitchA-Vlanif200] ip address 10.10.20.1 255.255.255.0  //Configure una dirección IP para VLANIF 200 para la comunicación con SwitchB.
      [SwitchA-Vlanif200] quit
      

      # Agregue la interfaz de enlace ascendente a VLAN 200.

      [SwitchA] interface gigabitethernet 1/0/3
      [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 200
      [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 200
      [SwitchA-GigabitEthernet1/0/3] quit
      

      # Configure un route estático por defecto.

      [SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.10.20.2  //La dirección del siguiente salto de la ruta corresponde a la dirección IP de VLANIF 200 en SwitchB.
      

    2. Configure SwitchB como servidor DHCP para asignar direcciones IP a teléfonos IP.

      # Configure un grupo de direcciones.

      <Quidway> system-view
      [Quidway] sysname SwitchB
      [SwitchB] ip pool ip-phone  //Cree un grupo de direcciones.
      [SwitchB-ip-pool-ip-phone] gateway-list 10.20.20.1  //Configure la dirección del gateway en el servidor DHCP.
      [SwitchB-ip-pool-ip-phone] network 10.20.20.0 mask 255.255.255.0  //Configure las direcciones IP asignables en el grupo de direcciones IP.
      [SwitchB-ip-pool-ip-phone] quit
      

      # Configure la función de servidor DHCP.

      [SwitchB] dhcp enable  //Habilite DHCP globalmente. Por defecto, DHCP está deshabilitado.
      [SwitchB] vlan batch 200
      [SwitchB] interface Vlanif 200  //Cree VLANIF 200.
      [SwitchB-Vlanif200] ip address 10.10.20.2 255.255.255.0  //Asigne una dirección IP a VLANIF 200.
      [SwitchB-Vlanif200] dhcp select global  //Configure SwitchB para asignar direcciones IP desde el grupo de direcciones IP global al teléfono IP.
      [SwitchB-Vlanif200] quit
      

      # Agregue la interfaz de enlace descendente a VLAN 200.

      [SwitchB] interface gigabitethernet 1/0/3
      [SwitchB-GigabitEthernet1/0/3] port hybrid pvid vlan 200
      [SwitchB-GigabitEthernet1/0/3] port hybrid untagged vlan 200
      [SwitchB-GigabitEthernet1/0/3] quit

      # Configurar un route de retorno.

      [SwitchB] ip route-static 10.20.20.0 255.255.255.0 10.10.20.1

  4. Configure un dominio AAA y autenticación de dirección MAC para teléfonos IP.
    1. Configure un dominio AAA.

      # Cree y configure una plantilla del servidor RADIUS.

      [SwitchA] radius-server template cisco  //Cree una plantilla de servidor RADIUS llamada cisco.
      [SwitchA-radius-cisco] radius-server authentication 192.168.6.182 1812  //Configure la dirección IP y el número de puertos del servidor de autenticación RADIUS.
      [SwitchA-radius-cisco] radius-server accounting 192.168.6.182 1813  //Configure la dirección IP y el número de puertos del servidor de contabilidad RADIUS.
      [SwitchA-radius-cisco] quit
      

      # Configure un esquema de autenticación.

      [SwitchA] aaa
      [SwitchA-aaa] authentication-scheme radius  //Cree un esquema de autenticación llamado radius.
      [SwitchA-aaa-authen-radius] authentication-mode radius  //Establezca el modo de autenticación a RADIUS.
      [SwitchA-aaa-authen-radius] quit
      

      # Cree un dominio AAA y vincule la plantilla del servidor RADIUS y el esquema de autenticación al dominio AAA.

      [SwitchA-aaa] domain default  //Configure un dominio llamado default.
      [SwitchA-aaa-domain-default] authentication-scheme radius  //Enlace el esquema de autenticación radius al dominio.
      [SwitchA-aaa-domain-default] radius-server cisco  //Enlace la plantilla del servidor RADIUS cisco al dominio.
      [SwitchA-aaa-domain-default] quit
      [SwitchA-aaa] quit
      

    2. Configure la autenticación de la dirección MAC para teléfonos IP y PC.

      • V200R007C00 y versiones anteriores, y V200R008C00

        # Ajuste el modo NAC a unificado.

        [SwitchA] authentication unified-mode  //Por defecto, el switch usa el modo unificado. Cuando se cambian los modos tradicional y unificado, el administrador debe guardar la configuración y reiniciar el switch para que la configuración tenga efecto.

        # Habilite la autenticación de la dirección MAC en una interfaz.

        [SwitchA] interface gigabitethernet 1/0/1
        [SwitchA-GigabitEthernet1/0/1] authentication mac-authen  //Habilite la autenticación de la dirección MAC.
        [SwitchA-GigabitEthernet1/0/1] quit
        [SwitchA] interface gigabitethernet 1/0/2
        [SwitchA-GigabitEthernet1/0/2] authentication mac-authen
        [SwitchA-GigabitEthernet1/0/2] quit
        
      • V200R009C00 y versiones posteriores

        # Ajuste el modo NAC a unificado.

        [SwitchA] authentication unified-mode  //Por defecto, el switch usa el modo unificado. Cuando se cambian los modos tradicional y unificado, el administrador debe guardar la configuración y reiniciar el switch para que la configuración tenga efecto.

        # Configure un perfil de acceso MAC.

        [SwitchA] mac-access-profile name cisco  //Cree un perfil de acceso MAC llamado cisco.
        [SwitchA-mac-access-profile-cisco] quit

        # Configure un perfil de autenticación.

        [SwitchA] authentication-profile name cisco  //Configure un perfil de autenticación.
        [SwitchA-authen-profile-cisco] mac-access-profile cisco  //Enlace el perfil de acceso MAC cisco al perfil de autenticación.
        [SwitchA-authen-profile-cisco] quit

        # Aplique el perfil de autenticación a las interfaces.

        [SwitchA] interface gigabitethernet 1/0/1
        [SwitchA-GigabitEthernet1/0/1] authentication-profile cisco  //Enlace el perfil de autenticación y habilite la autenticación de la dirección MAC.
        [SwitchA-GigabitEthernet1/0/1] quit
        [SwitchA] interface gigabitethernet 1/0/2
        [SwitchA-GigabitEthernet1/0/2] authentication-profile cisco
        [SwitchA-GigabitEthernet1/0/2] quit
        

    3. Configure el Agile Controller. La visualización del Agile Controller varía según la versión. V100R002C10SPC401 se usa como ejemplo.

      1. Inicie sesión en Agile Controller.

        Abra Internet Explorer, introduzca la dirección de acceso de Agile Controller en la barra de direcciones y presione Enter.

        Ingrese el nombre de usuario y la contraseña del administrador. Cuando inicie sesión en el Agile Controller por primera vez, use el nombre de usuario del super administrador admin y la contraseña Changeme123. Cambie la contraseña inmediatamente después de iniciar sesión. De lo contrario, el Agile Controller no se puede usar.

        Se pueden usar los siguientes modos de acceso de Agile Controller.

        Modo de acceso

        Descripción

        https://Agile Controller-IP:8443

        Agile Controller-IP especifica la dirección IP de Agile Controller.

        Dirección IP de Agile Controller

        Si el puerto 80 está habilitado durante la instalación, puede acceder al Agile Controller ingresando su dirección IP sin el número de puerto. La URL de Agile Controller cambiará automáticamente a https://Agile Controller-IP:8443.

      2. Agregue una dirección MAC.
        1. Elija Resource > User > User Management.
        2. Seleccione All Accounts.
        3. Haga clic en Add para crear dos cuentas MAC. El valor de MAC Account es la dirección MAC del teléfono IP.

      3. Agregue SwitchA al Agile Controller.
        1. Elija Resource > Device > Device Management.

        2. Haga clic en Add. En la página Add Device, agregue SwitchA, que se usa para autenticar teléfonos IP.

      4. Agregue un teléfono IP al Agile Controller.
        1. Elija Resource > Terminal > Terminal List.

        2. Haga clic en Add para acceder a la página Add Device Group.

        3. En la página Add Device Group, agregue un grupo de teléfonos IP.

        4. Haga clic en un grupo de dispositivos, seleccione cisco_ipphone, seleccione Device List, y haga clic en Add para agregar un teléfono IP.

      5. Agregue una regla de autenticación.

        Elija Policy > Permission Control > Authentication & Authorization > Authentication Rule y haga clic en Add para crear reglas de autenticación.

      6. Agregue un resultado de autorización.

        Elija Policy > Permission Control > Authentication & Authorization > Authorization Rule y haga clic en Add para crear un resultado de autorización.

  5. Verifique la configuración

    • Puede ver que el teléfono IP puede obtener correctamente el ID de VLAN de voz y la dirección IP a través del menú del teléfono IP.
    • La salida del comando display access-user en SwitchA muestra información de conexión sobre teléfonos IP.
      [SwitchA] display access-user
       ------------------------------------------------------------------------------ 
       UserID Username     IP address       MAC            Status          
       ------------------------------------------------------------------------------ 
       564   001bd4c71fa9  10.20.20.198     001b-d4c7-1fa9 Success        
       565   0021a08f2fa8  10.20.20.199     0021-a08f-2fa8 Success         
       ------------------------------------------------------------------------------ 
       Total: 2, printed: 2  

Archivos de configuración

  • Archivo de configuración de SwitchA (V200R007C00 y versiones anteriores, y V200R008C00)
    #
    sysname SwitchA
    #
    voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000
    voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000
    #
    vlan batch 100 200
    #
    dhcp enable
    #
    radius-server template cisco
     radius-server authentication 192.168.6.182 1812 weight 80
     radius-server accounting 192.168.6.182 1813 weight 80
    #
    aaa
     authentication-scheme radius
      authentication-mode radius
     domain default
      authentication-scheme radius
      radius-server cisco
    #
    interface Vlanif100
     ip address 10.20.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.10.20.2
    #
    interface Vlanif200
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1       
     voice-vlan 100 enable
     voice-vlan remark-mode mac-address
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     authentication mac-authen
    #
    interface GigabitEthernet1/0/2       
     voice-vlan 100 enable
     voice-vlan remark-mode mac-address
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     authentication mac-authen
    #
    interface GigabitEthernet1/0/3       
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    #
    return
    
  • Archivo de configuración de SwitchA (V200R009C00 y versiones posteriores)
    #
    sysname SwitchA
    #
    voice-vlan mac-address 001b-d4c7-0000 mask ffff-ffff-0000
    voice-vlan mac-address 0021-a08f-0000 mask ffff-ffff-0000
    #
    vlan batch 100 200
    #
    authentication-profile name cisco
     mac-access-profile cisco
    #
    dhcp enable
    #
    radius-server template cisco
     radius-server authentication 192.168.6.182 1812 weight 80
     radius-server accounting 192.168.6.182 1813 weight 80
    #
    aaa
     authentication-scheme radius
      authentication-mode radius
     domain default
      authentication-scheme radius
      radius-server cisco
    #
    interface Vlanif100
     ip address 10.20.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.10.20.2
    #
    interface Vlanif200
     ip address 10.10.20.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1       
     voice-vlan 100 enable
     voice-vlan remark-mode mac-address
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     authentication-profile cisco
    #
    interface GigabitEthernet1/0/2       
     voice-vlan 100 enable
     voice-vlan remark-mode mac-address
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     authentication-profile cisco
    #
    interface GigabitEthernet1/0/3       
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.10.20.2
    #
    mac-access-profile name cisco
    #
    return
    
  • Archivo de configuración de SwitchB
    #
    sysname SwitchB
    #
    vlan batch 200
    #
    dhcp enable
    #
    ip pool ip-phone
     gateway-list 10.20.20.1 
     network 10.20.20.0 mask 255.255.255.0 
    #
    interface Vlanif200
     ip address 10.10.20.2 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    ip route-static 10.20.20.0 255.255.255.0 10.10.20.1
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15696

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente