No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un switch de Capa 2 a trabajar con un router para acceso a Internet

Ejemplo para configurar un switch de Capa 2 a trabajar con un router para acceso a Internet

Switch de Capa 2

Los switches de Capa 2 solo realizan el reenvío de la Capa 2 en lugar del reenvío de la Capa 3. Es decir, los switches de Capa 2 solo admiten switches de Capa 2 en lugar de funciones de Capa 3, como el enrutamiento.

Los switches de Capa 2 normalmente se despliegan en la capa de acceso y no pueden funcionar como gateways de los usuarios.

Notas de configuración

Las configuraciones de switch utilizadas en este ejemplo se aplican a todas las versiones de todos los switches de la serie S.

Este ejemplo usa configuraciones de router de AR3600 V200R007C00SPCc00. Para otras configuraciones de router, consulte la documentación correspondiente.

Requisitos de redes

En Figura 2-19, una compañía tiene múltiples departamentos que pertenecen a diferentes segmentos de red, y cada departamento necesita acceder a Internet. Se requiere que los usuarios accedan a Internet a través del switch de Capa 2 y router y que el router funcione como el gateway de los usuarios.

Figura 2-19  Configuración de un switch de Capa 2 para trabajar con un router para acceso de Internet

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure la asignación de VLAN basada en la interfaz en el switch para el reenvío de Capa 2.

  2. Configure el router como el gateway de los usuarios para implementar el reenvío de Capa 3 a través de segmentos de red por subinterfaces o interfaces VLANIF.

  3. Configure el router como el servidor DHCP para asignar direcciones IP a los usuarios.

  4. Configure la función NAT en el router para admitir que los usuarios de la intranet tengan acceso a Internet.

Procedimiento

  1. Configure el switch.

    # Configure las interfaces conectadas a los usuarios.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 2 3
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access   //Establezca el tipo de enlace de la interfaz a access.
    [Switch-GigabitEthernet0/0/2] port default vlan 2   //Agregue la interfaz a VLAN 2.
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type access
    [Switch-GigabitEthernet0/0/3] port default vlan 3   
    [Switch-GigabitEthernet0/0/3] quit
    

    # Configure la interfaz conectada al router.

    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 3   //Configure la interfaz como una interfaz Trunk para transmitir paquetes de manera transparente de la VLAN 2 y la VLAN 3.
    [Switch-GigabitEthernet0/0/1] quit
    

  2. Configure el router.

    Hay dos métodos disponibles para configurar un router: uno es para configurar las subinterfaces y el otro es para configurar las interfaces VLANIF.

    • Configure el router para terminar las etiquetas de VLAN a través de subinterfaces para implementar el reenvío de Capa 3 por segmentos de red.

      # Configure las subinterfaces para la terminación de la etiqueta de VLAN.

      <Huawei> system-view
      [Huawei] sysname Router
      [Router] vlan batch 2 3
      [Router] interface gigabitethernet 0/0/1.1
      [Router-GigabitEthernet0/0/1.1] dot1q termination vid 2   
      [Router-GigabitEthernet0/0/1.1] ip address 192.168.1.1 24
      [Router-GigabitEthernet0/0/1.1] arp broadcast enable   //Por defecto, la difusión ARP en una subinterfaz de terminación de etiqueta VLAN está deshabilitada en routers AR en una versión anterior a V200R003C01 y habilitada en V200R003C01 y versiones posteriores.
      [Router-GigabitEthernet0/0/1.1] quit
      [Router] interface gigabitethernet 0/0/1.2
      [Router-GigabitEthernet0/0/1.2] dot1q termination vid 3   
      [Router-GigabitEthernet0/0/1.2] ip address 192.168.2.1 24
      [Router-GigabitEthernet0/0/1.2] arp broadcast enable    
      [Router-GigabitEthernet0/0/1.2] quit
      

      # Configure la función DHCP para asignar direcciones IP a usuarios de la intranet y especifique la dirección del servidor DNS.

      [Router] dhcp enable
      [Router] interface gigabitethernet 0/0/1.1
      [Router-GigabitEthernet0/0/1.1] dhcp select interface   //DHCP usa un grupo de direcciones de interfaz para asignar direcciones IP a usuarios de la intranet.
      [Router-GigabitEthernet0/0/1.1] dhcp server dns-list 114.114.114.114 223.5.5.5   //La lista DNS configurada 114.114.114.114 es una dirección pública del servidor DNS, que es la misma para los operadores. En la práctica, la dirección de la lista DNS debe configurarse según el DNS asignado a un operador.
      [Router-GigabitEthernet0/0/1.1] quit
      [Router] interface gigabitethernet 0/0/1.2
      [Router-GigabitEthernet0/0/1.2] dhcp select interface   
      [Router-GigabitEthernet0/0/1.2] dhcp server dns-list 114.114.114.114 223.5.5.5   
      [Router-GigabitEthernet0/0/1.2] quit
      

      # Configure una dirección IP de interfaz de red pública y una ruta estática.

      [Router] interface gigabitethernet 0/0/2
      [Router-GigabitEthernet0/0/2] ip address 200.0.0.2 255.255.255.0   //Configure una dirección IP 200.0.0.2 para GE0/0/2 conectado a la red pública.
      [Router-GigabitEthernet0/0/2] quit
      [Router] ip route-static 0.0.0.0 0.0.0.0 200.0.0.1   //Configure una ruta predeterminada estática con el siguiente salto apuntando a la dirección IP pública 200.0.0.1.
      

      # Configure la función NAT para admitir que los usuarios de la intranet tengan acceso a Internet.

      [Router] acl number 2001
      [Router-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255    //NAT tiene efecto solo para las direcciones IP de origen en el segmento de red 192.168.0.0/16 y traduce solo las direcciones IP de origen de los paquetes salientes en GE0/0/2.
      [Router-acl-basic-2001] quit
      [Router] interface gigabitethernet 0/0/2
      [Router-GigabitEthernet0/0/2] nat outbound 2001
      [Router-GigabitEthernet0/0/2] quit
      
    • Configure las interfaces VLANIF en el router para implementar el reenvío de Capa 3 a través de segmentos de red.

      # Configure las interfaces VLANIF.

      <Huawei> system-view
      [Huawei] sysname Router
      [Router] vlan batch 2 3
      [Router] interface gigabitethernet 0/0/1
      [Router-GigabitEthernet0/0/1] portswitch   //Cambie la interfaz Ethernet del modo de Capa 3 al modo de Capa 2. Si ha funcionado en el modo de Capa 2, omita este paso.
      [Router-GigabitEthernet0/0/1] port link-type trunk
      [Router-GigabitEthernet0/0/1] port trunk allow-pass vlan 2 3 
      [Router-GigabitEthernet0/0/1] quit
      [Router] interface vlanif 2
      [Router-vlanif2] ip address 192.168.1.1 24   //Configure la dirección IP de VLANIF2 como la dirección del gateway de PC1.
      [Router-vlanif2] quit
      [Router] interface vlanif 3
      [Router-vlanif3] ip address 192.168.2.1 24   //Configure la dirección IP de VLANIF3 como la dirección del gateway de PC2.
      [Router-vlanif3] quit
      

      # Configure la función DHCP para asignar direcciones IP a usuarios de la intranet y especifique la dirección del servidor DNS.

      [Router] dhcp enable
      [Router] interface vlanif 2 
      [Router-Vlanif2] dhcp select interface
      [Router-Vlanif2] dhcp server dns-list 114.114.114.114 223.5.5.5   //La lista DNS configurada 114.114.114.114 es una dirección pública del servidor DNS, que es la misma para los operadores. En la práctica, la dirección de la lista DNS debe configurarse según el DNS asignado a un operador.
      [Router-Vlanif2] quit
      [Router] interface vlanif 3
      [Router-Vlanif3] dhcp select interface
      [Router-Vlanif3] dhcp server dns-list 114.114.114.114 223.5.5.5
      [Router-Vlanif3] quit
      

      # Configure una dirección IP de interfaz de red pública y una ruta estática.

      [Router] interface gigabitethernet 0/0/2
      [Router-GigabitEthernet0/0/2] ip address 200.0.0.2 255.255.255.0
      [Router-GigabitEthernet0/0/2] quit
      [Router] ip route-static 0.0.0.0 0.0.0.0 200.0.0.1   //Configure una ruta predeterminada estática con el siguiente salto apuntando a la dirección IP pública 200.0.0.1.
      

      # Configure la función NAT para admitir que los usuarios de la intranet tengan acceso a Internet.

      [Router] acl number 2001
      [Router-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255   //NAT sólo tiene efecto para las direcciones IP de origen en el segmento de red 192.168.0.0/16 y traduce sólo direcciones IP de origen de paquetes salientes en GE0/0/2.
      [Router-acl-basic-2001] quit
      [Router] interface gigabitethernet 0/0/2
      [Router-GigabitEthernet0/0/2] nat outbound 2001
      [Router-GigabitEthernet0/0/2] quit
      

  3. Verifique la configuración

    Configure una dirección IP como 192.168.1.2/24 y una dirección de gateway como 192.168.1.1 para PC1, y configure una dirección IP como 192.168.2.2/24 y una dirección de gateway como 192.168.2.1 para PC2.

    Configure una dirección IP como 200.0.0.1/24 y una dirección de gateway como 200.0.0.2 para la red externa.

    Una vez completadas las configuraciones, PC1 y PC2 pueden hacer ping a la dirección IP 200.0.0.1/24 de la red externa y acceder a Internet.

Archivos de configuración

  • Archivo de configuración de Switch

    #
    sysname Switch
    #
    vlan batch 2 to 3
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 2
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 3
    #
    return
    
  • Archivo de configuración de Router (utilizado cuando el router realizan el reenvío de Capa 3 a través de subinterfaces)
    #
    sysname Router
    #
    vlan batch 2 to 3
    #
    dhcp enable
    #
    acl number 2001  
     rule 5 permit source 192.168.0.0 0.0.255.255 
    #
    interface GigabitEthernet0/0/1
    #
    interface GigabitEthernet0/0/1.1
     dot1q termination vid 2
     ip address 192.168.1.1 255.255.255.0 
     arp broadcast enable
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5 
    #
    interface GigabitEthernet0/0/1.2
     dot1q termination vid 3
     ip address 192.168.2.1 255.255.255.0 
     arp broadcast enable
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5 
    #
    interface GigabitEthernet0/0/2
     ip address 200.0.0.2 255.255.255.0 
     nat outbound 2001
    #
    ip route-static 0.0.0.0 0.0.0.0 200.0.0.1
    #
    return
    
  • El archivo de configuración del Router (se usa cuando el router realiza el reenvío de Capa 3 a través de las interfaces VLANIF)
    #
    sysname Router
    #
    vlan batch 2 to 3
    #
    dhcp enable
    #
    acl number 2001
     rule 5 permit source 192.168.0.0 0.0.255.255
    #
    interface Vlanif2
     ip address 192.168.1.1 255.255.255.0
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5
    #
    interface Vlanif3
     ip address 192.168.2.1 255.255.255.0
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5
    #
    interface GigabitEthernet0/0/1
     portswitch
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface GigabitEthernet0/0/2
     ip address 200.0.0.2 255.255.255.0
     nat outbound 2001
    #
    ip route-static 0.0.0.0 0.0.0.0 200.0.0.1
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15599

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente